summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2757ff491801..2c9f95e3c65a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = gbdk-2020
pkgdesc = An updated version of Game Boy Development Kit
- pkgver = 3.2
+ pkgver = 4.0.3
pkgrel = 2
- url = https://github.com/Zal0/gbdk-2020
+ url = https://github.com/gbdk-2020/gbdk-2020
arch = x86_64
arch = i686
license = MIT
- makedepends = sdcc
- depends = sdcc
+ makedepends = git
+ depends = sdcc=4.1.0
conflicts = gbdk
conflicts = lcc
- source = git+https://github.com/basxto/gbdk-2020#commit=01cdbb621afa61de77e394de76161bd8aa65848d
- sha256sums = SKIP
+ options = !strip
+ source = https://github.com/gbdk-2020/gbdk-2020/archive/4.0.3.tar.gz
+ sha256sums = 53d90bfa5ec63e1c39ceedb653acaed92309e8b5d34a2d1239717947f469e75f
pkgname = gbdk-2020
-
diff --git a/PKGBUILD b/PKGBUILD
index 8c548636399a..f558f858c95d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,27 @@
# based on gbdk package
pkgname=gbdk-2020
-pkgver=3.2
+pkgver=4.0.3
pkgrel=2
pkgdesc="An updated version of Game Boy Development Kit"
-url="https://github.com/Zal0/gbdk-2020"
+url="https://github.com/gbdk-2020/gbdk-2020"
license=('MIT')
arch=('x86_64' 'i686')
-makedepends=('sdcc')
-depends=('sdcc')
+makedepends=('git')
+depends=('sdcc=4.1.0')
conflicts=('gbdk' 'lcc')
-source=("git+https://github.com/basxto/gbdk-2020#commit=01cdbb621afa61de77e394de76161bd8aa65848d")
-#should be merged in the next version
-#source=("https://github.com/Zal0/gbdk-2020/archive/v${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("https://github.com/gbdk-2020/gbdk-2020/archive/${pkgver}.tar.gz")
+sha256sums=('53d90bfa5ec63e1c39ceedb653acaed92309e8b5d34a2d1239717947f469e75f')
+options=('!strip')
package() {
- sed "s|%prefix%bin/|/usr/bin/|g" -i ${pkgname}/gbdk-support/lcc/gb.c
- make -C ${pkgname} gbdk-build TARGETDIR=/opt/${pkgname} SDCCDIR=/usr/
- make -C ${pkgname} gbdk-install-nosdcc TARGETDIR=/opt/${pkgname} SDCCDIR=/usr/
- mkdir -p ${pkgdir}/usr
- mkdir -p ${pkgdir}/opt
+ make -C ${pkgname}-${pkgver} gbdk-build gbdk-support-install gbdk-lib-install TARGETDIR=/usr/share/${pkgname}/ BINDIR=/usr/bin/ SDCCDIR=/usr/
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}/
- mv ${pkgname}/build/gbdk ${pkgdir}/opt/${pkgname}
- mv ${pkgdir}/opt/${pkgname}/bin ${pkgdir}/usr/
- find ${pkgdir}/opt/${pkgname}/ -type f -name '*.bat' -delete
+ mv ${pkgname}-${pkgver}/build/gbdk ${pkgdir}/usr/share/${pkgname}
+ mv ${pkgdir}/usr/share/${pkgname}/bin ${pkgdir}/usr/
+ find ${pkgdir}/usr/share/${pkgname}/ -type f -name '*.bat' -delete -o -type f -name '*.dox' -delete
+ rm -rf ${pkgdir}/usr/share/${pkgname}/examples/
+ cp ${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
+ cp ${pkgname}-${pkgver}/gbdk-lib/build/small/asxxxx/gb/crt0.lst ${pkgdir}/usr/share/${pkgname}/lib/small/asxxxx/gb/
}