summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD109
2 files changed, 49 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e214466dad3..b1d408d6389f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Wed Sep 13 04:41:04 UTC 2017
pkgbase = gcc47-multilib
pkgdesc = The GNU Compiler Collection for multilib (4.7.x)
pkgver = 4.7.4
@@ -22,10 +20,12 @@ pkgbase = gcc47-multilib
options = staticlibs
options = !libtool
options = !emptydirs
+ options = !buildflags
source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.7.4/gcc-4.7.4.tar.bz2
source = gcc.texi.49.patch
+ md5sums = 4c696da46297de6ae77a82797d2abe28
+ md5sums = f3c42a9cfa840a062897da0468102771
sha256sums = 92e61c6dc3a0a449e62d72a38185fda550168a86702dea07125ebd3ec3996282
sha256sums = 9f8c50a715a921d3d2c9d5809ac9592ca66f682b2cc496606ff6eb4de79d46b6
pkgname = gcc47-multilib
-
diff --git a/PKGBUILD b/PKGBUILD
index e74ed07b4d4b..f329051a9ca9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
set -u
_pkgver='4.7'
-pkgname="gcc${_pkgver//\./}-multilib"
+pkgname="gcc${_pkgver//./}-multilib"
pkgver="${_pkgver}.4"
pkgrel='1'
pkgdesc="The GNU Compiler Collection for multilib (${_pkgver}.x)"
@@ -19,15 +19,16 @@ depends=('glibc>=2.17' 'binutils>=2.23' 'libmpc' 'cloog' 'ppl')
makedepends=('flex' 'bison' 'setconf')
#makedepends+=('gcc49')
checkdepends=('dejagnu')
-options=('staticlibs' '!libtool' '!emptydirs')
+options=('staticlibs' '!libtool' '!emptydirs' '!buildflags')
source=(
"ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
- #ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
+ #"ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2"
'gcc.texi.49.patch'
)
+md5sums=('4c696da46297de6ae77a82797d2abe28'
+ 'f3c42a9cfa840a062897da0468102771')
sha256sums=('92e61c6dc3a0a449e62d72a38185fda550168a86702dea07125ebd3ec3996282'
'9f8c50a715a921d3d2c9d5809ac9592ca66f682b2cc496606ff6eb4de79d46b6')
-PKGEXT='.pkg.tar.gz'
if [ -n "${_snapshot:-}" ]; then
_basedir="gcc-${_snapshot}"
@@ -70,73 +71,55 @@ build() {
set -u
if [ ! -s "${_basedir}/gcc-build/Makefile" ]; then
cd "${_basedir}"
- # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
- sed -e '/^ac_cpp=/ s/\$CPPFLAGS/\$CPPFLAGS -O2/' -i {libiberty,gcc}/configure
-
- # Doesn't like FORTIFY_SOURCE
- CPPFLAGS="${CPPFLAGS//-D_FORTIFY_SOURCE=?/}"
-
- # Doesn't like -fstack-protector-strong
- CFLAGS="${CFLAGS//-fstack-protector-strong/-fstack-protector}"
- CXXFLAGS="${CXXFLAGS//-fstack-protector-strong/-fstack-protector}"
-
- # using -pipe causes spurious test-suite failures
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS="${CFLAGS/-pipe/}"
- CXXFLAGS="${CXXFLAGS/-pipe/}"
-
- # Flags from new compilers that old compilers don't recognize
- CFLAGS="${CFLAGS/-fno-plt/}"
- CXXFLAGS="${CXXFLAGS/-fno-plt/}"
-
- CFLAGS="${CFLAGS/-Wformat-overflow=[0-9]/}"
- CXXFLAGS="${CXXFLAGS/-Wformat-overflow=[0-9]/}"
cd 'gcc-build'
# The following options are one per line, mostly sorted so they are easy to diff compare to other gcc packages.
- ../configure \
- --build="${CHOST}" \
- --disable-build-poststage1-with-cxx \
- --disable-build-with-cxx \
- --disable-cloog-version-check \
- --disable-libssp \
- --disable-libstdcxx-pch \
- --disable-libunwind-exceptions \
- --enable-multilib \
- --disable-ppl-version-check \
- --enable-__cxa_atexit \
- --enable-checking='release' \
- --enable-clocale='gnu' \
- --enable-cloog-backend='isl' \
- --enable-gnu-unique-object \
- --enable-gold \
- --enable-languages='c,c++,fortran' \
- --enable-ld='default' \
- --enable-libstdcxx-time \
- --enable-linker-build-id \
- --enable-lto \
- --enable-plugin \
- --enable-shared \
- --enable-threads='posix' \
- --enable-version-specific-runtime-libs \
- --infodir='/usr/share/info' \
- --libdir='/usr/lib' \
- --libexecdir='/usr/lib' \
- --mandir='/usr/share/man' \
- --program-suffix="-${_pkgver}" \
- --with-bugurl='https://bugs.archlinux.org/' \
- --with-linker-hash-style='gnu' \
- --with-plugin-ld='ld.gold' \
- --with-ppl \
- --with-system-zlib \
+ local _conf=(
+ --build="${CHOST}"
+ --disable-build-poststage1-with-cxx
+ --disable-build-with-cxx
+ --disable-cloog-version-check
+ --disable-libssp
+ --disable-libstdcxx-pch
+ --disable-libunwind-exceptions
+ --enable-multilib
+ --disable-ppl-version-check
+ --enable-__cxa_atexit
+ --enable-checking='release'
+ --enable-clocale='gnu'
+ --enable-cloog-backend='isl'
+ --enable-gnu-unique-object
+ --enable-gold
+ --enable-languages='c,c++,fortran'
+ --enable-ld='default'
+ --enable-libstdcxx-time
+ --enable-linker-build-id
+ --enable-lto
+ --enable-plugin
+ --enable-shared
+ --enable-threads='posix'
+ --enable-version-specific-runtime-libs
+ --infodir='/usr/share/info'
+ --libdir='/usr/lib'
+ --libexecdir='/usr/lib'
+ --mandir='/usr/share/man'
+ --program-suffix="-${_pkgver}"
+ --with-bugurl='https://bugs.archlinux.org/'
+ --with-linker-hash-style='gnu'
+ --with-plugin-ld='ld.gold'
+ --with-ppl
+ --with-system-zlib
--prefix='/usr'
-# CXX='g++-4.9' CC='gcc-4.9'
+ #CXX='g++-4.9' CC='gcc-4.9'
+ )
+ ../configure "${_conf[@]}"
+
+ sed -e 's/^STAGE1_CXXFLAGS.*$/& -std=gnu++11/' -i 'Makefile'
fi
cd "${srcdir}/${_basedir}/gcc-build"
- local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
LD_PRELOAD='/usr/lib/libstdc++.so' \
- nice make -j "${_nproc}"
+ nice make -s
set +u
}