summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD28
-rw-r--r--gcc.texi.49.patch78
3 files changed, 55 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffd8e093dbdf..0e214466dad3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jul 30 19:15:37 UTC 2017
+# Wed Sep 13 04:41:04 UTC 2017
pkgbase = gcc47-multilib
pkgdesc = The GNU Compiler Collection for multilib (4.7.x)
pkgver = 4.7.4
@@ -25,7 +25,7 @@ pkgbase = gcc47-multilib
source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.7.4/gcc-4.7.4.tar.bz2
source = gcc.texi.49.patch
sha256sums = 92e61c6dc3a0a449e62d72a38185fda550168a86702dea07125ebd3ec3996282
- sha256sums = 93b8865cb61f455df807de90f852dc488753d4309d7a1d8f7e7f1a4efe37ffa4
+ sha256sums = 9f8c50a715a921d3d2c9d5809ac9592ca66f682b2cc496606ff6eb4de79d46b6
pkgname = gcc47-multilib
diff --git a/PKGBUILD b/PKGBUILD
index 7940375ee437..e74ed07b4d4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,14 +26,14 @@ source=(
'gcc.texi.49.patch'
)
sha256sums=('92e61c6dc3a0a449e62d72a38185fda550168a86702dea07125ebd3ec3996282'
- '93b8865cb61f455df807de90f852dc488753d4309d7a1d8f7e7f1a4efe37ffa4')
+ '9f8c50a715a921d3d2c9d5809ac9592ca66f682b2cc496606ff6eb4de79d46b6')
PKGEXT='.pkg.tar.gz'
-#if [ -n "${_snapshot}" ]; then
-# _basedir="gcc-${_snapshot}"
-#else
+if [ -n "${_snapshot:-}" ]; then
+ _basedir="gcc-${_snapshot}"
+else
_basedir="gcc-${pkgver}"
-#fi
+fi
prepare() {
set -u
@@ -46,7 +46,12 @@ prepare() {
sed -e 's@\./fixinc\.sh@-c true@' -i 'gcc/Makefile.in'
# Update gcc.texi to gcc49 version, needed as of texinfo>=6.3 and possibly texinfo=6.2
- patch -p0 -c < "${srcdir}/gcc.texi.49.patch"
+ # diff -pNau5 gcc/doc/gcc.texi{,.49} > 'gcc.texi.49.patch'
+ patch -Nup0 -i "${srcdir}/gcc.texi.49.patch"
+
+ # fix build with glibc 2.26
+ sed -e 's:\bstruct ucontext\b:ucontext_t:g' -i $(grep --include '*.[ch]' --include '*.cc' -lre '\bstruct ucontext\b')
+ sed -e 's:\bstruct sigaltstack\b:stack_t:g' -i $(grep --include '*.[ch]' --include '*.cc' -lre '\bstruct sigaltstack\b')
# Arch Linux installs x86_64 libraries /lib
case "${CARCH}" in
@@ -63,9 +68,11 @@ prepare() {
build() {
set -u
- cd "${_basedir}/gcc-build"
+ if [ ! -s "${_basedir}/gcc-build/Makefile" ]; then
+ cd "${_basedir}"
+ # hack! - some configure tests for header files using "$CPP $CPPFLAGS"
+ sed -e '/^ac_cpp=/ s/\$CPPFLAGS/\$CPPFLAGS -O2/' -i {libiberty,gcc}/configure
- if [ ! -s 'Makefile' ]; then
# Doesn't like FORTIFY_SOURCE
CPPFLAGS="${CPPFLAGS//-D_FORTIFY_SOURCE=?/}"
@@ -85,6 +92,7 @@ build() {
CFLAGS="${CFLAGS/-Wformat-overflow=[0-9]/}"
CXXFLAGS="${CXXFLAGS/-Wformat-overflow=[0-9]/}"
+ cd 'gcc-build'
# The following options are one per line, mostly sorted so they are easy to diff compare to other gcc packages.
../configure \
--build="${CHOST}" \
@@ -125,6 +133,7 @@ build() {
# CXX='g++-4.9' CC='gcc-4.9'
fi
+ cd "${srcdir}/${_basedir}/gcc-build"
local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
LD_PRELOAD='/usr/lib/libstdc++.so' \
nice make -j "${_nproc}"
@@ -141,7 +150,7 @@ _fn_check() {
ulimit -s 32768
# do not abort on error as some are "expected"
- make -k check || :
+ make -j1 -k check || :
"${srcdir}/${_basedir}/contrib/test_summary"
set +u
}
@@ -150,6 +159,7 @@ package() {
set -u
cd "${_basedir}/gcc-build"
+ LD_PRELOAD='/usr/lib/libstdc++.so' \
make -j1 DESTDIR="${pkgdir}" install
## Lazy way of dealing with conflicting man and info pages and locales...
diff --git a/gcc.texi.49.patch b/gcc.texi.49.patch
index 056853ddb101..951eeb787001 100644
--- a/gcc.texi.49.patch
+++ b/gcc.texi.49.patch
@@ -1,44 +1,34 @@
-*** gcc/doc/gcc.texi Tue Jun 23 03:35:08 2015
---- gcc/doc/gcc.texi.49 Fri Jun 26 13:47:23 2015
-***************
-*** 83,93 ****
- Published by:
- @multitable @columnfractions 0.5 0.5
- @item GNU Press
-! @tab Website: www.gnupress.org
- @item a division of the
-! @tab General: @tex press@@gnu.org @end tex
- @item Free Software Foundation
-! @tab Orders: @tex sales@@gnu.org @end tex
- @item 51 Franklin Street, Fifth Floor
- @tab Tel 617-542-5942
- @item Boston, MA 02110-1301 USA
---- 83,93 ----
- Published by:
- @multitable @columnfractions 0.5 0.5
- @item GNU Press
-! @tab Website: @uref{http://www.gnupress.org}
- @item a division of the
-! @tab General: @email{press@@gnu.org}
- @item Free Software Foundation
-! @tab Orders: @email{sales@@gnu.org}
- @item 51 Franklin Street, Fifth Floor
- @tab Tel 617-542-5942
- @item Boston, MA 02110-1301 USA
-***************
-*** 140,146 ****
- * Gcov:: @command{gcov}---a test coverage program.
- * Trouble:: If you have trouble using GCC.
- * Bugs:: How, why and where to report bugs.
-! * Service:: How to find suppliers of support for GCC.
- * Contributing:: How to contribute to testing and developing GCC.
-
- * Funding:: How to help assure funding for free software.
---- 140,146 ----
- * Gcov:: @command{gcov}---a test coverage program.
- * Trouble:: If you have trouble using GCC.
- * Bugs:: How, why and where to report bugs.
-! * Service:: How To Get Help with GCC
- * Contributing:: How to contribute to testing and developing GCC.
-
- * Funding:: How to help assure funding for free software.
+--- gcc/doc/gcc.texi 2015-06-23 03:35:08.000000000 -0400
++++ gcc/doc/gcc.texi.49 2017-07-30 16:20:34.864415816 -0400
+@@ -81,15 +81,15 @@ This file documents the use of the GNU c
+ @page
+ @vskip 0pt plus 1filll
+ Published by:
+ @multitable @columnfractions 0.5 0.5
+ @item GNU Press
+-@tab Website: www.gnupress.org
++@tab Website: @uref{http://www.gnupress.org}
+ @item a division of the
+-@tab General: @tex press@@gnu.org @end tex
++@tab General: @email{press@@gnu.org}
+ @item Free Software Foundation
+-@tab Orders: @tex sales@@gnu.org @end tex
++@tab Orders: @email{sales@@gnu.org}
+ @item 51 Franklin Street, Fifth Floor
+ @tab Tel 617-542-5942
+ @item Boston, MA 02110-1301 USA
+ @tab Fax 617-542-2652
+ @end multitable
+@@ -138,11 +138,11 @@ Introduction, gccint, GNU Compiler Colle
+ * Objective-C:: GNU Objective-C runtime features.
+ * Compatibility:: Binary Compatibility
+ * Gcov:: @command{gcov}---a test coverage program.
+ * Trouble:: If you have trouble using GCC.
+ * Bugs:: How, why and where to report bugs.
+-* Service:: How to find suppliers of support for GCC.
++* Service:: How To Get Help with GCC
+ * Contributing:: How to contribute to testing and developing GCC.
+
+ * Funding:: How to help assure funding for free software.
+ * GNU Project:: The GNU Project and GNU/Linux.
+