summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--gcc-4.8-filename-output.patch17
3 files changed, 7 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc7d9902c81f..bb0e710f88bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by makepkg 4.2.1
-# Sat Jun 20 11:48:33 UTC 2015
pkgbase = gcc48
pkgdesc = The GNU Compiler Collection - C and C++ frontends (4.8.x)
- pkgver = 4.8.4
+ pkgver = 4.8.5
pkgrel = 1
url = http://gcc.gnu.org
arch = i686
@@ -23,10 +21,8 @@ pkgbase = gcc48
options = !emptydirs
options = staticlibs
options = !libtool
- source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.8.4/gcc-4.8.4.tar.bz2
- source = gcc-4.8-filename-output.patch
- md5sums = 5a84a30839b2aca22a2d723de2a626ec
- md5sums = 40cb437805e2f7a006aa0d0c3098ab0f
+ source = ftp://gcc.gnu.org/pub/gcc/releases/gcc-4.8.5/gcc-4.8.5.tar.bz2
+ md5sums = 80d2c2982a3392bb0b89673ff136e223
pkgname = gcc48
diff --git a/PKGBUILD b/PKGBUILD
index e63a109aa582..3f8e2da94ec1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=gcc48
_pkgver_minor=4.8
-pkgver=${_pkgver_minor}.4
+pkgver=${_pkgver_minor}.5
pkgrel=1
pkgdesc="The GNU Compiler Collection - C and C++ frontends (4.8.x)"
arch=('i686' 'x86_64')
@@ -19,10 +19,8 @@ depends=('binutils>=2.24' 'libmpc' 'cloog')
makedepends=('binutils>=2.24' 'libmpc' 'cloog' 'doxygen')
checkdepends=('dejagnu' 'inetutils')
options=('!emptydirs' 'staticlibs' '!libtool')
-source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
- gcc-4.8-filename-output.patch)
-md5sums=('5a84a30839b2aca22a2d723de2a626ec'
- '40cb437805e2f7a006aa0d0c3098ab0f')
+source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2)
+md5sums=('80d2c2982a3392bb0b89673ff136e223')
_basedir=gcc-${pkgver}
@@ -43,9 +41,6 @@ build() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57653
- patch -p0 -i ${srcdir}/gcc-4.8-filename-output.patch
-
# installing libiberty headers is broken
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56780#c6
sed -i 's#@target_header_dir@#libiberty#' libiberty/Makefile.in
@@ -115,7 +110,7 @@ package()
# create symlinks
cd ${pkgdir}/usr/bin
- for ii in c++ cpp g++ gcc gcc-ar gcc-nm gcc-ranlib gfortran; do
+ for ii in c++ g++ gcc gcc-ar gcc-nm gcc-ranlib gfortran; do
ln -s ${ii}-${pkgver} ${ii}-${_pkgver_minor}
ln -s ${CHOST}-${ii}-${pkgver} ${CHOST}-${ii}-${_pkgver_minor}
done
diff --git a/gcc-4.8-filename-output.patch b/gcc-4.8-filename-output.patch
deleted file mode 100644
index 6951eb239b77..000000000000
--- a/gcc-4.8-filename-output.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- gcc/c-family/c-opts.c (revision 200330)
-+++ gcc/c-family/c-opts.c (working copy)
-@@ -1338,10 +1338,14 @@ c_finish_options (void)
-
- /* Give CPP the next file given by -include, if any. */
- static void
- push_command_line_include (void)
- {
-+ // This can happen if disabled by -imacros for example.
-+ if (include_cursor > deferred_count)
-+ return;
-+
- if (!done_preinclude)
- {
- done_preinclude = true;
- if (flag_hosted && std_inc && !cpp_opts->preprocessed)
- {