summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac8da63f751e..2bc7f244f469 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = gce-compute-image-packages
pkgdesc = Linux Guest Environment for Google Compute Engine
- pkgver = 20170523
- pkgrel = 2
+ pkgver = 0.0.0
+ pkgrel = 1
url = https://github.com/GoogleCloudPlatform/compute-image-packages
- arch = any
+ arch = x86_64
license = Apache
depends = python-boto
depends = python-setuptools
- source = https://github.com/GoogleCloudPlatform/compute-image-packages/archive/20170523.tar.gz
- sha512sums = f72f46b962ef58b5d89a7eff0aff0abc3bb41fe33fd5fff0d8c2b2c08110f73316ed7fb0b6c9ea9c0c9a24760877a2b3da8facca81c15a47829b7a1af6bb2fd0
+ depends = git
+ source = gce-compute-image-packages::git://github.com/GoogleCloudPlatform/compute-image-packages.git
+ sha512sums = SKIP
pkgname = gce-compute-image-packages
diff --git a/PKGBUILD b/PKGBUILD
index 96cc8daf471c..1c085267f1f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
+# Maintainer: Alrii14344 <alrii14344@gmail.com>
# Maintainer: Kohei Suzuki <eagletmt@gmail.com>
+
pkgname=gce-compute-image-packages
-pkgver=20170523
-pkgrel=2
+pkgver=0.0.0
+pkgrel=1
pkgdesc='Linux Guest Environment for Google Compute Engine'
-arch=('any')
+arch=('x86_64')
url='https://github.com/GoogleCloudPlatform/compute-image-packages'
license=('Apache')
-depends=('python-boto' 'python-setuptools')
-source=("https://github.com/GoogleCloudPlatform/compute-image-packages/archive/${pkgver}.tar.gz")
+depends=('python-boto' 'python-setuptools' 'git')
+source=("$pkgname"::'git://github.com/GoogleCloudPlatform/compute-image-packages.git')
+# Because the sources are not static, skip Git checksum:
+sha512sums=('SKIP')
package() {
- cd "compute-image-packages-$pkgver"
+ cd "gce-compute-image-packages"
python setup.py install --root="$pkgdir"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -20,6 +24,4 @@ package() {
do
install -m644 "$unit" "$pkgdir/usr/lib/systemd/system/"
done
-}
-
-sha512sums=('f72f46b962ef58b5d89a7eff0aff0abc3bb41fe33fd5fff0d8c2b2c08110f73316ed7fb0b6c9ea9c0c9a24760877a2b3da8facca81c15a47829b7a1af6bb2fd0')
+} \ No newline at end of file