summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
-rw-r--r--gchecksum.install12
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88074e2e7c1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Thu May 28 12:35:09 UTC 2015
+pkgbase = gchecksum
+ pkgdesc = GUI frontend for system.util sums. C++ && Qt framework.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/gagiD/GCheckSum
+ install = gchecksum.install
+ arch = i686
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = GPL
+ makedepends = qt5-base
+ makedepends = desktop-file-utils
+ makedepends = gtk-update-icon-cache
+ depends = qt5-base
+ source = https://github.com/gagiD/GCheckSum/blob/master/pkg/gchecksum-0.1.tar.gz?raw=true
+ md5sums = SKIP
+
+pkgname = gchecksum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..149fd229410d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: gagiD <gagid@openmailbox.com>
+pkgname=gchecksum
+pkgver=0.1
+pkgrel=1
+pkgdesc="GUI frontend for system.util sums. C++ && Qt framework."
+arch=('i686' 'x86_64')
+url='https://github.com/gagiD/GCheckSum'
+license=('GPL')
+groups=('qt' 'qt5')
+makedepends=('qt5-base' 'desktop-file-utils' 'gtk-update-icon-cache')
+depends=('qt5-base')
+install='gchecksum.install'
+source=("https://github.com/gagiD/GCheckSum/blob/master/pkg/${pkgname}-${pkgver}.tar.gz?raw=true")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir"
+ qmake-qt5 PREFIX=/usr
+}
+
+build() {
+ cd "$srcdir"
+ make
+}
+
+check() {
+ cd "$srcdir"
+ make -k check
+}
+
+package() {
+ cd "$srcdir"
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/gchecksum.install b/gchecksum.install
new file mode 100644
index 000000000000..701dd39c5207
--- /dev/null
+++ b/gchecksum.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file