summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
-rw-r--r--duplicate_unsigned.patch16
3 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c25096e64b46..6a10ec9f5130 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = gcrontab
pkgdesc = a crontab editor with GUI
pkgver = 0.8
- pkgrel = 3
+ pkgrel = 4
url = http://www.arquired.es/users/aldelgado/proy/gcrontab/
arch = i686
+ arch = x86_64
license = GPL
depends = gtk
source = http://web.archive.org/web/20120427151653/http://www.arquired.es/users/aldelgado/proy/gcrontab/gcrontab-0.8.0.tgz
source = gcrontab.desktop
+ source = duplicate_unsigned.patch
md5sums = acd0797153d3aabe2242cc4dd61b1787
md5sums = 3d8a3522ef84fdafb785f730691091c6
+ md5sums = 1f1841c552aff16db1eb5d78083545c4
pkgname = gcrontab
diff --git a/PKGBUILD b/PKGBUILD
index a442e4a660c2..dcaca8af4c9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,24 @@
pkgname=gcrontab
pkgver=0.8
-pkgrel=3
+pkgrel=4
pkgdesc="a crontab editor with GUI"
-arch=('i686')
+arch=('i686' 'x86_64')
url="http://www.arquired.es/users/aldelgado/proy/gcrontab/"
license=('GPL')
depends=('gtk')
#source=("http://www.arquired.es/users/aldelgado/proy/${pkgname}/${pkgname}-${pkgver}.0.tgz" "gcrontab.desktop")
-source=("http://web.archive.org/web/20120427151653/http://www.arquired.es/users/aldelgado/proy/gcrontab/gcrontab-0.8.0.tgz" "gcrontab.desktop")
+source=("http://web.archive.org/web/20120427151653/http://www.arquired.es/users/aldelgado/proy/gcrontab/gcrontab-0.8.0.tgz"
+ "gcrontab.desktop"
+ "duplicate_unsigned.patch")
md5sums=('acd0797153d3aabe2242cc4dd61b1787'
- '3d8a3522ef84fdafb785f730691091c6')
+ '3d8a3522ef84fdafb785f730691091c6'
+ '1f1841c552aff16db1eb5d78083545c4')
+
+prepare() {
+ cd $srcdir/${pkgname}-${pkgver}.0
+ patch -p2 -i $srcdir/duplicate_unsigned.patch
+}
build() {
cd $srcdir/${pkgname}-${pkgver}.0
@@ -25,4 +33,5 @@ package() {
make DESTDIR=${pkgdir} install
install -D -m644 pixmaps/gcrontab.xpm $pkgdir/usr/share/pixmaps/gcrontab.xpm
install -D -m644 $srcdir/gcrontab.desktop $pkgdir/usr/share/applications/gcrontab.desktop
+ rm $pkgdir/usr/share/locale/locale.alias
}
diff --git a/duplicate_unsigned.patch b/duplicate_unsigned.patch
new file mode 100644
index 000000000000..faa18789f13c
--- /dev/null
+++ b/duplicate_unsigned.patch
@@ -0,0 +1,16 @@
+diff -aur src.orig/gcrontab-0.8.0/config.h.in src/gcrontab-0.8.0/config.h.in
+--- src.orig/gcrontab-0.8.0/config.h.in 2021-04-26 00:31:19.560384869 +0200
++++ src/gcrontab-0.8.0/config.h.in 2021-04-26 00:31:32.767068048 +0200
+@@ -22,12 +22,6 @@
+ /* Define as __inline if that's what the C compiler calls it. */
+ #undef inline
+
+-/* Define to `long' if <sys/types.h> doesn't define. */
+-#undef off_t
+-
+-/* Define to `unsigned' if <sys/types.h> doesn't define. */
+-#undef size_t
+-
+ /* If using the C implementation of alloca, define if you know the
+ direction of stack growth for your system; otherwise it will be
+ automatically deduced at run-time.