summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d64f291c60c..97985fe97c91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gcsfuse
pkgdesc = A user-space file system for interacting with Google Cloud Storage
- pkgver = 2.0.1
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/GoogleCloudPlatform/gcsfuse
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = gcsfuse
depends = glibc
depends = fuse
optdepends = google-cloud-sdk: authentication helper
- source = gcsfuse-2.0.1::https://github.com/GoogleCloudPlatform/gcsfuse/archive/refs/tags/v2.0.1.tar.gz
- sha256sums = 834dfc23970f33725ddafe73c4b9afa9232197894599f5e93b528df007740944
+ source = gcsfuse-2.1.0::https://github.com/GoogleCloudPlatform/gcsfuse/archive/refs/tags/v2.1.0.tar.gz
+ sha256sums = b3232cbe92d2a49dcec25e0360a6c6ced562516d93a89e51b38dfacb65eafe7f
pkgname = gcsfuse
diff --git a/PKGBUILD b/PKGBUILD
index cdb3dec815e6..919f81b69d9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: zfo <zfoofz1@gmail.com>
pkgname=gcsfuse
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=1
pkgdesc="A user-space file system for interacting with Google Cloud Storage"
url="https://github.com/GoogleCloudPlatform/gcsfuse"
@@ -15,13 +15,13 @@ depends=('glibc' 'fuse')
makedepends=('git' 'go')
optdepends=('google-cloud-sdk: authentication helper')
source=("$pkgname-$pkgver::https://github.com/GoogleCloudPlatform/gcsfuse/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('834dfc23970f33725ddafe73c4b9afa9232197894599f5e93b528df007740944')
-_gourl=github.com/googlecloudplatform/gcsfuse
+sha256sums=('b3232cbe92d2a49dcec25e0360a6c6ced562516d93a89e51b38dfacb65eafe7f')
+_gourl=github.com/googlecloudplatform/gcsfuse/v2
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- go build "$_gourl/v2"
- CGO_ENABLED=1 go build -buildmode=pie -o "mount.gcsfuse" "$_gourl/v2/tools/mount_gcsfuse"
+ go build "$_gourl"
+ CGO_ENABLED=1 go build -buildmode=pie -o "mount.gcsfuse" "$_gourl/tools/mount_gcsfuse"
}
package() {