summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD32
3 files changed, 25 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5ec931e3532..6d64f291c60c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = gcsfuse
pkgdesc = A user-space file system for interacting with Google Cloud Storage
- pkgver = 0.29.0
- pkgrel = 3
+ pkgver = 2.0.1
+ pkgrel = 1
url = https://github.com/GoogleCloudPlatform/gcsfuse
arch = x86_64
license = APACHE
makedepends = git
- makedepends = go-pie
+ makedepends = go
depends = glibc
+ depends = fuse
optdepends = google-cloud-sdk: authentication helper
- source = gcsfuse-0.29.0::https://github.com/GoogleCloudPlatform/gcsfuse/archive/v0.29.0.tar.gz
- sha256sums = 4f994d694a12691b7ea5bd293c50ba4a37bc329cf531780015daf0a5fd265b30
+ source = gcsfuse-2.0.1::https://github.com/GoogleCloudPlatform/gcsfuse/archive/refs/tags/v2.0.1.tar.gz
+ sha256sums = 834dfc23970f33725ddafe73c4b9afa9232197894599f5e93b528df007740944
pkgname = gcsfuse
-
diff --git a/.gitignore b/.gitignore
index f87bf283dd7f..4367ae4a50ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-pkg/
-src/
-gcsfuse-*
-*.pkg.tar*
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d77d4a5dabaa..75f574619e72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,32 @@
-# Maintainer: stocki <mail at firstname lastname dot de>
+# Maintainer: Josef Vybíhal <josef.vybihal@gmail.com>
+# Contributor: Sebastiaan Tammer <sebastiaantammer at gmail dot com>
+# Contributor: stocki <mail at firstname lastname dot de>
# Contributor: aimileus <me at aimileus dot nl>
# Contributor: zfo <zfoofz1@gmail.com>
+
pkgname=gcsfuse
-pkgver=0.29.0
-pkgrel=3
+pkgver=2.0.1
+pkgrel=1
pkgdesc="A user-space file system for interacting with Google Cloud Storage"
url="https://github.com/GoogleCloudPlatform/gcsfuse"
arch=('x86_64')
license=('APACHE')
-depends=('glibc')
-makedepends=('git' 'go-pie')
+depends=('glibc' 'fuse')
+makedepends=('git' 'go')
optdepends=('google-cloud-sdk: authentication helper')
-source=("$pkgname-$pkgver::https://github.com/GoogleCloudPlatform/gcsfuse/archive/v$pkgver.tar.gz")
-sha256sums=('4f994d694a12691b7ea5bd293c50ba4a37bc329cf531780015daf0a5fd265b30')
-_gourl=github.com/googlecloudplatform/gcsfuse
-
-prepare() {
- export GOPATH="$srcdir/go"
- mkdir -p "$GOPATH/src/$(dirname $_gourl)"
- ln -sf "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$_gourl"
-}
+source=("$pkgname-$pkgver::https://github.com/GoogleCloudPlatform/gcsfuse/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('834dfc23970f33725ddafe73c4b9afa9232197894599f5e93b528df007740944')
+_gourl=github.com/googlecloudplatform/gcsfuse/v2
build() {
- export GOPATH="$srcdir/go"
+ cd "${srcdir}/${pkgname}-${pkgver}"
go build "$_gourl"
CGO_ENABLED=1 go build -buildmode=pie -o "mount.gcsfuse" "$_gourl/tools/mount_gcsfuse"
}
package() {
- install -Dm755 gcsfuse "${pkgdir}/usr/bin/gcsfuse"
- install -Dm755 mount.gcsfuse "${pkgdir}/usr/bin/mount.gcsfuse"
+ install -Dm 755 "${srcdir}/${pkgname}-${pkgver}/gcsfuse" "${pkgdir}/usr/bin/gcsfuse"
+ install -Dm 755 "${srcdir}/${pkgname}-${pkgver}/mount.gcsfuse" "${pkgdir}/usr/bin/mount.gcsfuse"
cd "${pkgdir}/usr/bin" && ln -s mount.gcsfuse mount.fuse.gcsfuse
}
+