summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cafc1f4125ea..368753da8a82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
-# Generated by mksrcinfo v8
-# Wed Feb 10 13:49:50 UTC 2016
pkgbase = gcsfuse
pkgdesc = A user-space file system for interacting with Google Cloud Storage
- pkgver = 0.16
+ pkgver = 0.23.0
pkgrel = 1
url = https://github.com/GoogleCloudPlatform/gcsfuse
- arch = i686
arch = x86_64
license = APACHE
makedepends = git
- makedepends = go
+ makedepends = go-pie
+ depends = glibc
+ optdepends = google-cloud-sdk: authentication helper
+ source = gcsfuse-0.23.0::https://github.com/GoogleCloudPlatform/gcsfuse/archive/v0.23.0.tar.gz
+ sha256sums = beb90ef68d5ab673bf09357c90d1ace94695bebb6f823ba715a92b30e61e7c39
pkgname = gcsfuse
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f87bf283dd7f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+gcsfuse-*
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index 66189ae99b9c..2432ef247f20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
-# Maintainer: zfo <zfoofz1@gmail.com>
+# Maintainer: aimileus <me at aimileus dot nl>
+# Contributor: zfo <zfoofz1@gmail.com>
pkgname=gcsfuse
-_pkgname=gcsfuse
-pkgver=0.16
+pkgver=0.23.0
pkgrel=1
pkgdesc="A user-space file system for interacting with Google Cloud Storage"
url="https://github.com/GoogleCloudPlatform/gcsfuse"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('APACHE')
-makedepends=('git' 'go')
-source=()
-sha256sums=()
+depends=('glibc')
+makedepends=('git' 'go-pie')
+optdepends=('google-cloud-sdk: authentication helper')
+source=("$pkgname-$pkgver::https://github.com/GoogleCloudPlatform/gcsfuse/archive/v$pkgver.tar.gz")
+sha256sums=('beb90ef68d5ab673bf09357c90d1ace94695bebb6f823ba715a92b30e61e7c39')
+_gourl=github.com/googlecloudplatform/gcsfuse
+
+prepare() {
+ export GOPATH="$srcdir/go"
+ mkdir -p "$GOPATH/src/$(dirname $_gourl)"
+ ln -sf "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$_gourl"
+}
build() {
- GOPATH="$srcdir" go get -v -u github.com/googlecloudplatform/gcsfuse
+ export GOPATH="$srcdir/go"
+ go build "$_gourl"
}
package() {
- cd "$srcdir"
- install -Dm0755 bin/gcsfuse "${pkgdir}/usr/bin/gcsfuse"
+ install -Dm755 gcsfuse "${pkgdir}/usr/bin/gcsfuse"
}
# vim:set ts=2 sw=2 et: