summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6f51fcc4a19..b5ec931e3532 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gcsfuse
pkgdesc = A user-space file system for interacting with Google Cloud Storage
pkgver = 0.29.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/GoogleCloudPlatform/gcsfuse
arch = x86_64
license = APACHE
diff --git a/PKGBUILD b/PKGBUILD
index 1d5ebd072788..d77d4a5dabaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: zfo <zfoofz1@gmail.com>
pkgname=gcsfuse
pkgver=0.29.0
-pkgrel=2
+pkgrel=3
pkgdesc="A user-space file system for interacting with Google Cloud Storage"
url="https://github.com/GoogleCloudPlatform/gcsfuse"
arch=('x86_64')
@@ -24,9 +24,11 @@ prepare() {
build() {
export GOPATH="$srcdir/go"
go build "$_gourl"
+ CGO_ENABLED=1 go build -buildmode=pie -o "mount.gcsfuse" "$_gourl/tools/mount_gcsfuse"
}
package() {
install -Dm755 gcsfuse "${pkgdir}/usr/bin/gcsfuse"
- ln -s ${pkgdir}/usr/bin/gcsfuse ${pkgdir}/usr/bin/mount.gcsfuse
+ install -Dm755 mount.gcsfuse "${pkgdir}/usr/bin/mount.gcsfuse"
+ cd "${pkgdir}/usr/bin" && ln -s mount.gcsfuse mount.fuse.gcsfuse
}