summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad58d5b37416..bb2b62d4a1ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,8 @@ pkgbase = gdlauncher-bin
conflicts = gdlauncher
conflicts = gdlauncher-git
source_x86_64 = GDLauncher-1.1.8.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v1.1.8/GDLauncher-linux-setup.zip
+ source_x86_64 = https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png
+ md5sums_x86_64 = SKIP
md5sums_x86_64 = SKIP
pkgname = gdlauncher-bin
diff --git a/PKGBUILD b/PKGBUILD
index dccb3f1957f8..eeb4b1529365 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,18 +13,14 @@ makedepends=('gendesk' 'wget')
depends=('libnotify' 'libxss' 'libxtst' 'libindicator-gtk3' 'libappindicator-gtk3')
conflicts=('gdlauncher-appimage' 'gdlauncher' 'gdlauncher-git')
source_x86_64=(
- "GDLauncher-${pkgver}.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v${pkgver}/GDLauncher-linux-setup.zip"
-)
+ "GDLauncher-${pkgver}.zip::https://github.com/gorilla-devs/GDLauncher/releases/download/v${pkgver}/GDLauncher-linux-setup.zip" "https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png")
-md5sums_x86_64=('SKIP')
+md5sums_x86_64=('SKIP' 'SKIP')
prepare() {
# Generate .desktop
gendesk --pkgname "GDLauncher" --pkgdesc "${pkgdesc}" --icon ${pkgname} --exec "/usr/bin/${pkgname}" -n -f
mv "GDLauncher.desktop" "${pkgname}.desktop"
-
- # Download icon
- wget https://github.com/gorilla-devs/GDLauncher/raw/master/public/icon.png
}
package() {