summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--issue_166.patch32
-rw-r--r--pull_147.patch68
-rw-r--r--pull_154_utf8.patch12
5 files changed, 6 insertions, 125 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb75d8741e90..672f4fa22663 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Nov 10 19:07:49 UTC 2016
+# Thu Nov 30 01:04:00 UTC 2017
pkgbase = gdrivefs
pkgdesc = A complete FUSE adapter for Google Drive
- pkgver = 0.14.8
- pkgrel = 2
+ pkgver = 0.14.9
+ pkgrel = 3
url = https://github.com/dsoprea/GDriveFS
arch = any
license = GPL2
@@ -17,8 +17,8 @@ pkgbase = gdrivefs
depends = python2-dateutil
depends = python2-six
depends = python2-wsgiref
- source = https://github.com/dsoprea/GDriveFS/archive/0.14.8.tar.gz
- sha256sums = 7c7f0f8f3b7079f7823c0d27c751f3ae43c0ca0e7f6bbdf93da6dc29150890b5
+ source = https://github.com/dsoprea/GDriveFS/archive/0.14.9.tar.gz
+ sha256sums = eacc6633716823d93ca4a3ac5e1aaeeaa49513051136d6f8df681667cbc882d5
pkgname = gdrivefs
diff --git a/PKGBUILD b/PKGBUILD
index d2a0bdc1f61a..03a33223c9d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=gdrivefs
_gitname=GDriveFS
pkgver=0.14.9
-pkgrel=2
+pkgrel=3
pkgdesc='A complete FUSE adapter for Google Drive'
url='https://github.com/dsoprea/GDriveFS'
depends=('python2' 'python2-fusepy' 'python2-gevent' 'python2-google-api-python-client'
@@ -18,13 +18,6 @@ sha256sums=('eacc6633716823d93ca4a3ac5e1aaeeaa49513051136d6f8df681667cbc882d5')
build() {
cd ${srcdir}/${_gitname}-${pkgver}
-
- # Fix for multi threaded (issue 132)
- patch -p1 < ../../pull_147.patch
-
- # Add support to utf8 instead of ASCII
- patch -p1 < ../../pull_154_utf8.patch
-
python2 setup.py build
}
diff --git a/issue_166.patch b/issue_166.patch
deleted file mode 100644
index a85c8b80edc8..000000000000
--- a/issue_166.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- GDriveFS-0.14.8_orig/gdrivefs/gdtool/chunked_download.py 2016-07-16 17:27:28.000000000 +0200
-+++ GDriveFS-0.14.8/gdrivefs/gdtool/chunked_download.py 2016-11-10 15:58:06.000000000 +0100
-@@ -2,7 +2,10 @@
- import time
- import random
-
--import oauth2client
-+try:
-+ from oauth2client import util
-+except ImportError:
-+ from oauth2client import _helpers as util
- import apiclient.http
- import apiclient.errors
-
-@@ -19,7 +22,7 @@
- that needs to be downloaded (not a request object, which doesn't apply here).
- """
-
-- @oauth2client.util.positional(4)
-+ @util.positional(4)
- def __init__(self, fd, http, uri, chunksize=DEFAULT_CHUNK_SIZE, start_at=0):
- """Constructor.
-
-@@ -43,7 +46,7 @@
- self._sleep = time.sleep
- self._rand = random.random
-
-- @oauth2client.util.positional(1)
-+ @util.positional(1)
- def next_chunk(self, num_retries=0):
- """Get the next chunk of the download.
-
diff --git a/pull_147.patch b/pull_147.patch
deleted file mode 100644
index f5f4c4664add..000000000000
--- a/pull_147.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-diff --git a/gdrivefs/config/__init__.py b/gdrivefs/config/__init__.py
-index f8c4749..3646db3 100644
---- a/gdrivefs/config/__init__.py
-+++ b/gdrivefs/config/__init__.py
-@@ -1,4 +1,5 @@
- import os
-
- IS_DEBUG = bool(int(os.environ.get('GD_DEBUG', '0')))
-+NO_THREADS = bool(int(os.environ.get('GD_NOTHREADS', '1')))
- DO_LOG_FUSE_MESSAGES = bool(int(os.environ.get('GD_DO_LOG_FUSE_MESSAGES', '0')))
-diff --git a/gdrivefs/resources/README.rst b/gdrivefs/resources/README.rst
-index 6e25a7c..f7400d2 100644
---- a/gdrivefs/resources/README.rst
-+++ b/gdrivefs/resources/README.rst
-@@ -225,6 +225,20 @@ Just set the `GD_DEBUG` environment variable to "1"::
- flags=0x00000011
-
-
-+Multi-threading FUSE
-+====================
-+
-+It used to be that GDFS mounting used FUSE with no threads, only when running in
-+debugging-mode, and actually if not in debugging-mode, FUSE was always used
-+with threads.
-+
-+Currently, using FUSE with threads corrupts data reads, once mounted. Then now
-+multi-threading is decoupled from debugging-mode, and by default set to no threads.
-+
-+To enable threads back when mounting GDFS, just set the `GD_NOTHREADS` environment
-+variable to "0" (1 by default).
-+
-+
- Troubleshooting Steps
- =====================
-
-diff --git a/gdrivefs/resources/scripts/gdfs b/gdrivefs/resources/scripts/gdfs
-index b001787..a8673ff 100755
---- a/gdrivefs/resources/scripts/gdfs
-+++ b/gdrivefs/resources/scripts/gdfs
-@@ -40,7 +40,7 @@ def main():
- auth_storage_filepath=args.auth_storage_file,
- mountpoint=args.mountpoint,
- debug=gdrivefs.config.IS_DEBUG,
-- nothreads=gdrivefs.config.IS_DEBUG,
-+ nothreads=gdrivefs.config.NO_THREADS,
- option_string=option_string)
-
- if __name__ == '__main__':
-diff --git a/gdrivefs/resources/scripts/gdfstool b/gdrivefs/resources/scripts/gdfstool
-index da2820e..52aaf66 100755
---- a/gdrivefs/resources/scripts/gdfstool
-+++ b/gdrivefs/resources/scripts/gdfstool
-@@ -68,7 +68,7 @@ def _handle_mountpoint(args):
- auth_storage_filepath=args.auth_storage_file,
- mountpoint=args.mountpoint,
- debug=gdrivefs.config.IS_DEBUG,
-- nothreads=gdrivefs.config.IS_DEBUG,
-+ nothreads=gdrivefs.config.NO_THREADS,
- option_string=option_string)
-
- def main():
-@@ -122,4 +122,4 @@ def main():
- raise Exception("Invalid option.")
-
- if __name__ == '__main__':
-- main()
-\ No newline at end of file
-+ main()
diff --git a/pull_154_utf8.patch b/pull_154_utf8.patch
deleted file mode 100644
index 66279be938d3..000000000000
--- a/pull_154_utf8.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur GDriveFS-0.14.3-orig/gdrivefs/gdtool/normal_entry.py GDriveFS-0.14.3/gdrivefs/gdtool/normal_entry.py
---- GDriveFS-0.14.3-orig/gdrivefs/gdtool/normal_entry.py 2016-03-20 20:40:04.593869779 -0600
-+++ GDriveFS-0.14.3/gdrivefs/gdtool/normal_entry.py 2016-03-20 20:41:27.672855022 -0600
-@@ -213,7 +213,7 @@
- return data
-
- def get_data(self):
-- original = dict([(key.encode('ASCII'), value)
-+ original = dict([(key.encode('utf8'), value)
- for key, value
- in self.__raw_data.iteritems()])
-