summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3834dd88009a..9910d585b7ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = gdu-git
pkgdesc = Fast disk usage analyzer
- pkgver = v1.4.0.r1.g67d9865
+ pkgver = v1.6.0.r2.gcbf4718
pkgrel = 1
url = https://github.com/Dundee/gdu
arch = x86_64
license = MIT
makedepends = go
conflicts = gdu
+ conflicts = gdu-bin
source = gdu::git+https://github.com/Dundee/gdu
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 438ffbb3002b..500333c2c927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=gdu-git
_gitname=gdu
-pkgver=v1.4.0.r1.g67d9865
+pkgver=v1.6.0.r2.gcbf4718
pkgrel=1
license=('MIT')
pkgdesc="Fast disk usage analyzer"
makedepends=('go')
-conflicts=("gdu")
+conflicts=("gdu" "gdu-bin")
arch=('x86_64')
url="https://github.com/Dundee/gdu"
source=("$_gitname::git+https://github.com/Dundee/gdu")
@@ -25,7 +25,7 @@ build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
- go build -o $_gitname .
+ go build -ldflags="-s -w -X 'main.AppVersion=$pkgver'" -o $_gitname .
}
package() {