summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--geany-snippets.install8
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11d56635f0a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = geany-snippets
+ pkgdesc = Snippets for Geany
+ pkgver = 1
+ pkgrel = 5
+ url = http://www.geany.org/Download/Extras#snippets
+ install = geany-snippets.install
+ arch = any
+ license = GPL
+ depends = geany
+ source = http://lara.craft.net.br/snippets.conf
+ source = geany-snippets.install
+ md5sums = e6c32d7cb454deffe86cb32f62840f34
+ md5sums = 2011316bb069109d9fc3dbcfb784a73f
+
+pkgname = geany-snippets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23c8d96f7e08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Lara Maia <lara@craft.net.br>
+# Contribuitor: Sagar Chalise <chalisesagar@gmail.com>
+
+pkgname=geany-snippets
+pkgver=1
+pkgrel=5
+pkgdesc="Snippets for Geany"
+arch=('any')
+url="http://www.geany.org/Download/Extras#snippets"
+license=('GPL')
+depends=('geany')
+
+source=(http://lara.craft.net.br/snippets.conf
+ $pkgname.install)
+
+install=$pkgname.install
+
+md5sums=('e6c32d7cb454deffe86cb32f62840f34'
+ '2011316bb069109d9fc3dbcfb784a73f')
+
+package() {
+ cd "$srcdir"
+
+ install -Dm644 snippets.conf "$pkgdir"/usr/share/geany/snippets.conf.new
+}
diff --git a/geany-snippets.install b/geany-snippets.install
new file mode 100644
index 000000000000..c47e4a4cef20
--- /dev/null
+++ b/geany-snippets.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Snippets installed on /usr/share/geany/snippets.conf.new"
+ echo "To use, rename snippets.conf.new to snippets.conf"
+}
+
+post_upgrade() {
+ post_install
+}