summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
-rw-r--r--geary-enchant2.patch46
3 files changed, 32 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eb48e50f94b..cd74375fe057 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = geary-git
pkgdesc = A lightweight email client for the GNOME desktop
- pkgver = r3568.4ac7c10f
+ pkgver = r3615.17551d17
pkgrel = 1
url = https://wiki.gnome.org/Apps/Geary
arch = i686
arch = x86_64
license = GPL3
- makedepends = cmake
+ makedepends = meson
makedepends = gnome-doc-utils
makedepends = gobject-introspection
makedepends = intltool
@@ -35,7 +35,7 @@ pkgbase = geary-git
source = git://git.gnome.org/geary
source = geary-enchant2.patch
sha256sums = SKIP
- sha256sums = 87a0adc3d07a6bd6405c8170eea5be700ef89b70d15c8912b428c9326a746078
+ sha256sums = 23261cd5ff7b3a602d6e6e5bbf8cfce05d975026be476cfd120a98000d0aa5c6
pkgname = geary-git
diff --git a/PKGBUILD b/PKGBUILD
index 830405ca9674..3a78dbd6034a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Massimiliano Torromeo <massimiliano.torromeo at gmail dot com>
pkgname=geary-git
-pkgver=r3568.4ac7c10f
+pkgver=r3615.17551d17
pkgrel=1
pkgdesc="A lightweight email client for the GNOME desktop"
arch=(i686 x86_64)
@@ -13,14 +13,14 @@ license=('GPL3')
depends=('cairo' 'enchant' 'gcr' 'gdk-pixbuf2' 'glib2' 'glibc' 'gmime'
'gnome-keyring' 'gtk3' 'iso-codes' 'libcanberra' 'libgee' 'libnotify'
'libsecret' 'libsoup' 'libxml2' 'pango' 'sqlite' 'webkit2gtk')
-makedepends=('cmake' 'gnome-doc-utils' 'gobject-introspection' 'intltool'
+makedepends=('meson' 'gnome-doc-utils' 'gobject-introspection' 'intltool'
'vala')
provides=('geary')
conflicts=('geary')
source=('git://git.gnome.org/geary'
'geary-enchant2.patch')
sha256sums=('SKIP'
- '87a0adc3d07a6bd6405c8170eea5be700ef89b70d15c8912b428c9326a746078')
+ '23261cd5ff7b3a602d6e6e5bbf8cfce05d975026be476cfd120a98000d0aa5c6')
pkgver() {
cd "$srcdir/geary"
@@ -29,31 +29,19 @@ pkgver() {
prepare() {
cd "$srcdir/geary"
-
if [[ -d build ]]; then
rm -rf build
fi
- mkdir build
-
patch -Np1 -i ../geary-enchant2.patch
}
build() {
cd "$srcdir/geary"
-
- cd build
-
- cmake .. \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DDESKTOP_UPDATE='FALSE' \
- -DICON_UPDATE='FALSE' \
- -DGSETTINGS_COMPILE='FALSE' \
- -DGSETTINGS_COMPILE_IN_PLACE='FALSE'
- make
+ meson --prefix=/usr --buildtype=release build
+ ninja -v -C build
}
package() {
cd "$srcdir/geary"
- cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" ninja -v -C build install
}
diff --git a/geary-enchant2.patch b/geary-enchant2.patch
index 3b0a98076119..364f24fd57f0 100644
--- a/geary-enchant2.patch
+++ b/geary-enchant2.patch
@@ -1,24 +1,24 @@
-diff -rupN geary-0.12.0.orig/CMakeLists.txt geary-0.12.0/CMakeLists.txt
---- geary-0.12.0.orig/CMakeLists.txt 2018-01-16 21:45:14.731988942 +0100
-+++ geary-0.12.0/CMakeLists.txt 2018-01-16 21:47:51.510178769 +0100
-@@ -96,7 +96,7 @@ find_package(PkgConfig)
- pkg_check_modules(LIBUNITY QUIET unity>=5.12.0)
- pkg_check_modules(LIBMESSAGINGMENU QUIET messaging-menu>=12.10.2)
+diff --u a/meson.build b/meson.build
+--- a/meson.build
++++ b/meson.build
+@@ -51,7 +51,18 @@
+ webkit2gtk = dependency('webkit2gtk-4.0', version: '>=' + target_webkit)
+
+ # Secondary deps - keep sorted alphabetically
+-enchant = dependency('enchant', version: '>= 1.6')
++enchant = dependency('enchant', version: '>= 1.6', required: false)
++if not enchant.found()
++ dependency('enchant-2', version: '>= 1.6')
++ enchant = valac.find_library(
++ 'enchant',
++ dirs: '/usr/share/vala-0.40/vapi/',
++ required: true
++ )
++ # TODO These arguments should be applied more specifically
++ add_project_arguments('-I/usr/include/enchant-2/', language : 'c')
++ add_project_link_arguments('-lenchant-2', language : 'c')
++endif
+ gcr = dependency('gcr-3', version: '>= 3.10.1')
+ gdk = dependency('gdk-3.0', version: '>=' + target_gtk)
+ gee = dependency('gee-0.8', version: '>= 0.8.5')
--pkg_check_modules(ENCHANT QUIET enchant)
-+pkg_check_modules(ENCHANT QUIET enchant-2)
-
- pkg_check_modules(SQLITE3 sqlite3 REQUIRED)
- if (NOT ${SQLITE3_VERSION} VERSION_LESS 3.12)
-diff -rupN geary-0.12.0.orig/src/CMakeLists.txt geary-0.12.0/src/CMakeLists.txt
---- geary-0.12.0.orig/src/CMakeLists.txt 2018-01-16 21:45:14.738655384 +0100
-+++ geary-0.12.0/src/CMakeLists.txt 2018-01-16 21:48:40.088633141 +0100
-@@ -508,7 +508,7 @@ pkg_check_modules(DEPS REQUIRED
- webkit2gtk-4.0>=${TARGET_WEBKIT}
- webkit2gtk-web-extension-4.0>=${TARGET_WEBKIT}
- javascriptcoregtk-4.0>=${TARGET_WEBKIT}
-- enchant>=1.6
-+ enchant-2>=1.6
- libunwind-generic>=1.1
- ${EXTRA_CLIENT_PKG_CONFIG}
- )