summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c664b2a43eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gedit-autotab-git
+ pkgdesc = Automatically detect tab preferences for source files
+ pkgver = r45.cc70af2
+ pkgrel = 1
+ url = https://github.com/kapouer/gedit-autotab
+ arch = any
+ license = GPL3
+ depends = gedit
+ source = git+https://github.com/kapouer/gedit-autotab.git
+ sha256sums = SKIP
+
+pkgname = gedit-autotab-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13e4ebfff4ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ilya Basin <basinilya@gmail.com>
+# Contributor: Evangelos Foutras <foutrelis@gmail.com>
+
+_pkgname=gedit-autotab
+pkgname=gedit-autotab-git
+pkgver=r45.cc70af2
+pkgrel=1
+pkgdesc="Automatically detect tab preferences for source files"
+arch=('any')
+url="https://github.com/kapouer/gedit-autotab"
+license=('GPL3')
+depends=('gedit')
+source=('git+https://github.com/kapouer/gedit-autotab.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/gedit-autotab"
+ #patch -Np1 -i "$srcdir/nosavelistener.patch"
+ install -d "$pkgdir/usr/lib/gedit/plugins"
+ install -m644 -t "$pkgdir/usr/lib/gedit/plugins/" autotab.{plugin,py}
+}
+
+# vim:set ts=2 sw=2 et:
+