summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD9
3 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 316ae2b62cdc..81cb37c77872 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gedit-plugin-markdown_preview-git
pkgdesc = A gedit plugin previewing markdown (.md) documents
- pkgver = r106.c259554
+ pkgver = r110.b878f0c
pkgrel = 1
url = https://github.com/maoschanz/gedit-plugin-markdown_preview
arch = any
@@ -12,8 +12,6 @@ pkgbase = gedit-plugin-markdown_preview-git
optdepends = pymdown-extensions: extra Python Markdown extensions
optdepends = python-pygments: for CodeHilite extension
optdepends = pandoc: export and stylesheet support
- optdepends = texlive-bin: export to PDF with pandoc
- optdepends = texlive-core: export to PDF with pandoc
provides = gedit-plugin-markdown_preview
conflicts = gedit-plugin-markdown_preview
source = git+https://github.com/maoschanz/gedit-plugin-markdown_preview.git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index e6afefdf2b7a..417c606261a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=gedit-plugin-markdown_preview-git
-pkgver=r106.c259554
+pkgver=r110.b878f0c
pkgrel=1
pkgdesc="A gedit plugin previewing markdown (.md) documents"
arch=('any')
@@ -11,9 +11,7 @@ depends=('gedit' 'python-markdown' 'webkit2gtk')
makedepends=('git')
optdepends=('pymdown-extensions: extra Python Markdown extensions'
'python-pygments: for CodeHilite extension'
- 'pandoc: export and stylesheet support'
- 'texlive-bin: export to PDF with pandoc'
- 'texlive-core: export to PDF with pandoc')
+ 'pandoc: export and stylesheet support')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/maoschanz/gedit-plugin-markdown_preview.git')
@@ -31,4 +29,7 @@ package() {
install -Dm644 markdown_preview.plugin -t "$pkgdir/usr/lib/gedit/plugins"
cp -r markdown_preview "$pkgdir/usr/lib/gedit/plugins"
install -Dm644 example.css -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+
+ rm "$pkgdir/usr/lib/gedit/plugins/markdown_preview/locale/gedit-plugin-markdown-preview.pot"
+ rm "$pkgdir"/usr/lib/gedit/plugins/markdown_preview/locale/{fr,nl}/LC_MESSAGES/*.po
}