summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD50
2 files changed, 32 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eecc9a007dac..1ccd9fa1af39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gegl-git
pkgdesc = Graph based image processing framework
- pkgver = 0.4.4.177
+ pkgver = 0.4.9.d77fd17e0
pkgrel = 1
url = http://www.gegl.org
arch = i686
@@ -31,11 +31,11 @@ pkgbase = gegl-git
optdepends = libraw: raw plugin
optdepends = suitesparse: matting-levin plugin
optdepends = lua: lua plugin
- provides = gegl=0.4.4.177
+ provides = gegl=0.4.9.d77fd17e0
conflicts = gegl
options = !libtool
source = git+https://gitlab.gnome.org/GNOME/gegl.git
- md5sums = SKIP
+ sha512sums = SKIP
pkgname = gegl-git
diff --git a/PKGBUILD b/PKGBUILD
index ab882f865ed4..6bc1aceeb31c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Filipe Laíns (FFY00) <filipe.lains@gmail.com>
+# Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
# Contributor: Iru Cai <mytbk920423@gmail.com>
# Contributor: Alexander Hunziker <alex.hunziker@gmail.com>
# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=gegl-git
-pkgver=0.4.4.177
+_pkgname=${pkgname%-git}
+pkgver=0.4.9.d77fd17e0
pkgrel=1
pkgdesc="Graph based image processing framework"
arch=('i686' 'x86_64')
@@ -23,37 +24,44 @@ optdepends=('openexr: for using the openexr plugin'
'libraw: raw plugin'
'suitesparse: matting-levin plugin'
'lua: lua plugin')
-provides=("gegl=${pkgver}")
+provides=("gegl=$pkgver")
conflicts=('gegl')
options=(!libtool)
-source=(git+https://gitlab.gnome.org/GNOME/gegl.git)
-md5sums=('SKIP')
+source=('git+https://gitlab.gnome.org/GNOME/gegl.git')
+sha512sums=('SKIP')
-_gitroot=GITURL
-_gitname=gegl
+pkgver() {
+ cd $_pkgname
+
+ echo $(cat configure.ac | grep '^m4_define(\[gegl_.*_version\], \[[0-9]\])' | tr -d '\n' | sed -e 's|^m4_define(\[gegl_major_version\], \[||' -e 's|\])m4_define(\[gegl_minor_version\], \[|.|' -e 's|\])m4_define(\[gegl_micro_version\], \[|.|' -e 's|\])|\n|').$(git log --pretty=format:'%h' -n 1)
+}
prepare() {
- cd "$srcdir"/$_gitname
+ cd $_pkgname
+
+ autoreconf -if
- autoreconf -if
- ./configure --prefix=/usr --with-sdl --with-openexr --with-librsvg \
- --with-libavformat --with-jasper --disable-docs \
- --enable-workshop \
- --enable-introspection=yes
+ ./configure \
+ --prefix=/usr \
+ --with-sdl \
+ --with-openexr \
+ --with-librsvg \
+ --with-libavformat \
+ --with-jasper \
+ --disable-docs \
+ --enable-workshop \
+ --enable-introspection=yes
}
build() {
- cd "$srcdir"/$_gitname
+ cd $_pkgname
- make
+ make
}
package() {
- cd "$srcdir"/$_gitname
- make DESTDIR="$pkgdir" install
-}
+ cd $_pkgname
-pkgver() {
- cd "$srcdir"/$_gitname
- git describe --always | sed -e 's/GEGL_//' -e 's/-g.*$//' -e 's/[_-]/./g'
+ make DESTDIR="$pkgdir" install
}
+