summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85fbef034e9e..1285cf9a0074 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gegl-git
pkgdesc = Graph based image processing framework
- pkgver = 0.4.0.8
+ pkgver = 0.4.2.9
pkgrel = 1
url = http://www.gegl.org
arch = i686
@@ -31,10 +31,10 @@ pkgbase = gegl-git
optdepends = libraw: raw plugin
optdepends = suitesparse: matting-levin plugin
optdepends = lua: lua plugin
- provides = gegl=0.4.0.8
+ provides = gegl=0.4.2.9
conflicts = gegl
options = !libtool
- source = git://git.gnome.org/gegl
+ source = git+https://gitlab.gnome.org/GNOME/gegl.git
md5sums = SKIP
pkgname = gegl-git
diff --git a/PKGBUILD b/PKGBUILD
index 5469064b0b4c..690fe10ade0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Iru Cai <mytbk920423@gmail.com>
+# Maintainer: Filipe LaĆ­ns (FFY00) <filipe.lains@gmail.com>
+# Contributor: Iru Cai <mytbk920423@gmail.com>
# Contributor: Alexander Hunziker <alex.hunziker@gmail.com>
# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=gegl-git
-pkgver=0.4.0.8
+pkgver=0.4.2.9
pkgrel=1
pkgdesc="Graph based image processing framework"
arch=('i686' 'x86_64')
@@ -25,29 +26,29 @@ optdepends=('openexr: for using the openexr plugin'
provides=("gegl=${pkgver}")
conflicts=('gegl')
options=(!libtool)
-source=(git://git.gnome.org/gegl)
+source=(git+https://gitlab.gnome.org/GNOME/gegl.git)
md5sums=('SKIP')
_gitroot=GITURL
_gitname=gegl
build() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$_gitname"
- ./autogen.sh
- ./configure --prefix=/usr --with-sdl --with-openexr --with-librsvg \
- --with-libavformat --with-jasper --disable-docs \
- --enable-workshop \
- --enable-introspection=yes
+ ./autogen.sh
+ ./configure --prefix=/usr --with-sdl --with-openexr --with-librsvg \
+ --with-libavformat --with-jasper --disable-docs \
+ --enable-workshop \
+ --enable-introspection=yes
make
}
package() {
- cd "$srcdir/$_gitname"
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_gitname"
+ make DESTDIR="$pkgdir/" install
}
pkgver() {
- cd $_gitname
- git describe --always | sed -e 's/GEGL_//' -e 's/-g.*$//' -e 's/[_-]/./g'
+ cd $_gitname
+ git describe --always | sed -e 's/GEGL_//' -e 's/-g.*$//' -e 's/[_-]/./g'
}