summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
-rw-r--r--genymotion-beta.desktop9
-rw-r--r--genymotion-beta.install25
-rw-r--r--genymotion-player-beta.desktop10
5 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd46d667bdb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = genymotion-beta
+ pkgdesc = Complete set of tools that provides a virtual environment for Android. Beta Release
+ pkgver = 3.1.0beta3
+ pkgrel = 1
+ url = http://www.genymotion.com/
+ install = genymotion-beta.install
+ arch = x86_64
+ license = custom
+ depends = libpng
+ depends = net-tools
+ depends = protobuf
+ depends = qca-qt5
+ depends = qt5-script
+ depends = qt5-webkit
+ depends = virtualbox
+ provides = genymotion
+ conflicts = genymotion
+ source = genymotion-beta.desktop
+ source = genymotion-player-beta.desktop
+ source = genymotion-beta.install
+ source = https://dl.genymotion.com/releases/genymotion-3.1.0-beta3/genymotion-3.1.0-beta3-linux_x64.bin
+ sha512sums = b0d3363bedab53d01d701811b511aa233661c78e454e9d6ee75cc6241b23db13672dbc9723dd19417d1650b87ce44d3869cf39fb3104162074190f10172dbad4
+ sha512sums = a16a04b311f1b2194db4fe032c355b39e57d8473195788c1f18b1806ec051ecf8285e93e50c5dc98375678712e6410360aa959ca09c673043da788a8892c0a42
+ sha512sums = 7d1214bc270c9758e61b9f451699bea03485983ade2f3308e33ce6e4e1689c6d29ba16fdb7f297e03d866e78e0c5f6febfb63447848f07caf7b2f093aebb9c09
+ sha512sums = 6c08a6e9f7aaf40cab5a76e7d45fd31a73773ff2a2c6eda525dc814584016daa6636facb608f64e5e093779ecc66c561bc7ddc1778d9efa365a71b9e56df09e9
+
+pkgname = genymotion-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e47c01d1c03b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+#Maintainer: Arafat Zahan <kuasha420@gmail.com>
+#Contributor: Ekin Dursun <ekindursun@gmail.com>
+#Contributor: danyf90 <daniele.formichelli@gmail.com>
+#Contributor: syncrtl64 <syncrtl64@gmail.com>
+#Contributor: Andrea Cattaneo <andrea.cattaneo.dev@gmail.com>
+# https://dl.genymotion.com/releases/genymotion-3.1.0-beta3/genymotion-3.1.0-beta3-linux_x64.bin
+pkgname=genymotion-beta
+_pkgname=genymotion
+pkgver=3.1.0beta3
+_pkgver=3.1.0-beta3
+pkgrel=1
+pkgdesc="Complete set of tools that provides a virtual environment for Android. Beta Release"
+arch=('x86_64')
+provides=("genymotion")
+conflicts=("genymotion")
+url="http://www.genymotion.com/"
+depends=('libpng' 'net-tools' 'protobuf' 'qca-qt5' 'qt5-script' 'qt5-webkit' 'virtualbox')
+install=$pkgname.install
+license=('custom')
+_ARCH="x64"
+source=("genymotion-beta.desktop"
+ "genymotion-player-beta.desktop"
+ "genymotion-beta.install"
+ "https://dl.genymotion.com/releases/$_pkgname-$_pkgver/$_pkgname-$_pkgver-linux_$_ARCH.bin")
+sha512sums=('b0d3363bedab53d01d701811b511aa233661c78e454e9d6ee75cc6241b23db13672dbc9723dd19417d1650b87ce44d3869cf39fb3104162074190f10172dbad4'
+ 'a16a04b311f1b2194db4fe032c355b39e57d8473195788c1f18b1806ec051ecf8285e93e50c5dc98375678712e6410360aa959ca09c673043da788a8892c0a42'
+ '7d1214bc270c9758e61b9f451699bea03485983ade2f3308e33ce6e4e1689c6d29ba16fdb7f297e03d866e78e0c5f6febfb63447848f07caf7b2f093aebb9c09'
+ '6c08a6e9f7aaf40cab5a76e7d45fd31a73773ff2a2c6eda525dc814584016daa6636facb608f64e5e093779ecc66c561bc7ddc1778d9efa365a71b9e56df09e9')
+
+package(){
+ cd $srcdir
+
+ install -d $pkgdir/opt
+ yes | bash ./$_pkgname-$_pkgver-linux_$_ARCH.bin -d $pkgdir/opt
+
+ install -d $pkgdir/usr/bin
+ ln -s /opt/genymotion/genymotion $pkgdir/usr/bin/genymotion
+ ln -s /opt/genymotion/genymotion-shell $pkgdir/usr/bin/genymotion-shell
+ ln -s /opt/genymotion/player $pkgdir/usr/bin/genymotion-player
+ ln -s /opt/genymotion/gmtool $pkgdir/usr/bin/gmtool
+ install -Dm644 $srcdir/genymotion-beta.desktop $pkgdir/usr/share/applications/genymotion-beta.desktop
+ install -Dm644 $srcdir/genymotion-player-beta.desktop $pkgdir/usr/share/applications/genymotion-player-beta.desktop
+ chown -R root:root $pkgdir/opt/genymotion
+}
diff --git a/genymotion-beta.desktop b/genymotion-beta.desktop
new file mode 100644
index 000000000000..e06b2d17547f
--- /dev/null
+++ b/genymotion-beta.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Genymotion Beta
+Comment=Virtual environment for Android. Beta Version
+Exec=/usr/bin/genymotion
+Icon=/opt/genymotion/icons/icon.png
+Terminal=false
+Categories=Development; \ No newline at end of file
diff --git a/genymotion-beta.install b/genymotion-beta.install
new file mode 100644
index 000000000000..da5db1a8fe71
--- /dev/null
+++ b/genymotion-beta.install
@@ -0,0 +1,25 @@
+adv(){
+ echo -e "make sure to have this modules loaded: \n\tvboxdrv\n\tvboxnetflt\n\tvboxnetadp\n\tvboxpci"
+ echo "you can simply add them to /etc/modules-load.d/virtualbox.conf with this command:"
+ echo "# echo -e \"vboxdrv\\nvboxnetflt\\nvboxnetadp\\nvboxpci\" > /etc/modules-load.d/virtualbox.conf"
+}
+
+remove_slink(){
+ # in previous version install script created symbolic links
+ [[ -s /usr/local/bin/genymotion ]] && rm /usr/local/bin/genymotion
+ [[ -s /usr/local/bin/genymotion-shell ]] && rm /usr/local/bin/genymotion-shell
+}
+
+post_install() {
+ adv
+}
+
+post_upgrade() {
+ remove_slink
+ adv
+}
+
+post_remove() {
+ remove_slink
+}
+
diff --git a/genymotion-player-beta.desktop b/genymotion-player-beta.desktop
new file mode 100644
index 000000000000..43959da8887f
--- /dev/null
+++ b/genymotion-player-beta.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Genymotion Player Beta
+Comment=Virtual environment for Android. Beta Version
+Exec=/usr/bin/genymotion-player
+Icon=/opt/genymotion/icons/icon.png
+Terminal=false
+Categories=Development;
+StartupWMClass=Genymotion Player