summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f9ae7c5e119..cc47e28532d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = geonkick-git
pkgdesc = A free software percussion synthesizer (git version)
- pkgver = 1.6.1.r510.96f8bd7
+ pkgver = 1.9.0.r586.455574b
pkgrel = 1
- url = http://quamplex.com/geonkick
+ url = https://gitlab.com/geontime/geonkick
arch = i386
arch = x86_64
groups = pro-audio
@@ -21,7 +21,7 @@ pkgbase = geonkick-git
optdepends = jack: for stand-alone application
provides = geonkick
conflicts = geonkick
- source = geonkick::git+https://gitlab.com/quamplex/geonkick.git
+ source = geonkick::git+https://gitlab.com/geontime/geonkick.git
sha512sums = SKIP
pkgname = geonkick-git
diff --git a/PKGBUILD b/PKGBUILD
index 82993b758555..a861a3f52434 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_pkgname=geonkick
pkgname="${_pkgname}-git"
-pkgver=1.6.1.r510.96f8bd7
+pkgver=1.9.0.r586.455574b
pkgrel=1
pkgdesc="A free software percussion synthesizer (git version)"
arch=('i386' 'x86_64')
-url="http://quamplex.com/geonkick"
+url="https://gitlab.com/geontime/geonkick"
license=('GPL3')
groups=('pro-audio')
depends=('cairo' 'desktop-file-utils' 'hicolor-icon-theme' 'libsndfile' 'shared-mime-info')
@@ -14,7 +14,7 @@ makedepends=('cmake' 'jack' 'lv2' 'rapidjson' 'redkite' 'sord')
optdepends=('jack: for stand-alone application')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://gitlab.com/quamplex/geonkick.git")
+source=("${_pkgname}::git+https://gitlab.com/geontime/geonkick.git")
sha512sums=('SKIP')
@@ -26,8 +26,8 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- # fix ignored CMAKE_INSTALL_PREFIX for redkite include directory
- sed -i -e 's|/usr/local|${CMAKE_INSTALL_PREFIX}|' CMakeLists.txt
+ # don't call post-install commands
+ sed -i -e '/^install.CODE/d' data/CMakeLists.txt
}
build() {
@@ -37,6 +37,7 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DGKICK_REDKITE_SDK_PATH=/usr \
..
make
}
@@ -49,7 +50,7 @@ package() {
)
install -vDm 644 "data/${_pkgname}.desktop" \
-t "${pkgdir}/usr/share/applications"
- install -vDm 644 examples/* \
- -t "${pkgdir}/usr/share/doc/${pkgname}/examples"
+ install -dm 755 "${pkgdir}/usr/share/doc/${pkgname}/examples"
+ cp -r --preserve=mode examples/* "${pkgdir}/usr/share/doc/${pkgname}/examples"
install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}