summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD55
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f9ae7c5e119
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = geonkick-git
+ pkgdesc = A free software percussion synthesizer (git version)
+ pkgver = 1.6.1.r510.96f8bd7
+ pkgrel = 1
+ url = http://quamplex.com/geonkick
+ arch = i386
+ arch = x86_64
+ groups = pro-audio
+ license = GPL3
+ makedepends = cmake
+ makedepends = jack
+ makedepends = lv2
+ makedepends = rapidjson
+ makedepends = redkite
+ makedepends = sord
+ depends = cairo
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = libsndfile
+ depends = shared-mime-info
+ optdepends = jack: for stand-alone application
+ provides = geonkick
+ conflicts = geonkick
+ source = geonkick::git+https://gitlab.com/quamplex/geonkick.git
+ sha512sums = SKIP
+
+pkgname = geonkick-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2f6dfb32eb33
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+geonkick/
+pkg/
+src/
+geonkick-git-*.tar.xz
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82993b758555
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot -de>
+
+_pkgname=geonkick
+pkgname="${_pkgname}-git"
+pkgver=1.6.1.r510.96f8bd7
+pkgrel=1
+pkgdesc="A free software percussion synthesizer (git version)"
+arch=('i386' 'x86_64')
+url="http://quamplex.com/geonkick"
+license=('GPL3')
+groups=('pro-audio')
+depends=('cairo' 'desktop-file-utils' 'hicolor-icon-theme' 'libsndfile' 'shared-mime-info')
+makedepends=('cmake' 'jack' 'lv2' 'rapidjson' 'redkite' 'sord')
+optdepends=('jack: for stand-alone application')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://gitlab.com/quamplex/geonkick.git")
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ local ver="$(grep 'geonkick VERSION' CMakeLists.txt | cut -d ' ' -f 3 | tr -d ')')"
+ echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ # fix ignored CMAKE_INSTALL_PREFIX for redkite include directory
+ sed -i -e 's|/usr/local|${CMAKE_INSTALL_PREFIX}|' CMakeLists.txt
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p build
+ cd build
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ (
+ cd build
+ make DESTDIR="$pkgdir/" install
+ )
+ install -vDm 644 "data/${_pkgname}.desktop" \
+ -t "${pkgdir}/usr/share/applications"
+ install -vDm 644 examples/* \
+ -t "${pkgdir}/usr/share/doc/${pkgname}/examples"
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}