summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d9475d5d65c..3b496a4c403e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = geos-git
pkgdesc = C++ port of the Java Topology Suite (git version)
- pkgver = 3.8.0dev.4c70abae
+ pkgver = 3.10.0dev.7b70ce97
pkgrel = 1
url = http://trac.osgeo.org/geos/
arch = i686
arch = x86_64
license = LGPL
- depends = gcc-libs
- depends = bash
+ makedepends = cmake
+ makedepends = git
provides = geos
conflicts = geos
source = geos-git::git+https://git.osgeo.org/gitea/geos/geos.git
diff --git a/PKGBUILD b/PKGBUILD
index 8811b914b9b6..454873423122 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: peippo <christoph.fink@gmail.com>
pkgname=geos-git
-pkgver=3.8.0dev.4c70abae
+pkgver=3.10.0dev.7b70ce97
pkgrel=1
pkgdesc="C++ port of the Java Topology Suite (git version)"
url="http://trac.osgeo.org/geos/"
-license=('LGPL')
+license=("LGPL")
-arch=('i686' 'x86_64')
-depends=('gcc-libs' 'bash')
-conflicts=('geos')
-provides=('geos')
+arch=("i686" "x86_64")
+makedepends=("cmake" "git")
+conflicts=("geos")
+provides=("geos")
source=("${pkgname}::git+https://git.osgeo.org/gitea/geos/geos.git")
-md5sums=('SKIP')
+md5sums=("SKIP")
pkgver() {
cd "${pkgname}"
@@ -27,13 +27,16 @@ pkgver() {
}
build() {
- cd "${pkgname}"
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cmake \
+ -B build \
+ -S "${pkgname}" \
+ -DCMAKE_BUILD_TYPE="None" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -Wno-dev
+ make -C build
}
package() {
- cd "${pkgname}"
+ cd "build"
make DESTDIR="${pkgdir}" install
}