summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD27
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c48b89d1f7d7..52ed44652485 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = getgauge
pkgdesc = Light weight cross-platform test automation tool for authoring test cases in the business language.
pkgver = 1.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://getgauge.io
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 348246f58766..3611319c7862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=getgauge
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Light weight cross-platform test automation tool for authoring test cases in the business language."
arch=('x86_64' 'i686')
url="https://getgauge.io"
@@ -12,25 +12,24 @@ makedepends=('go')
source=("https://github.com/getgauge/gauge/archive/v$pkgver.tar.gz")
sha256sums=('89b47749ef134e57295849e89a10fadf577e05aeb690e9db013c39e9c59b1f5d')
-_gourl="/github.com/getgauge/gauge"
+_gauge_path="github.com/getgauge/gauge"
-prepare() {
+prepare() {
cd "$srcdir"
- mkdir -p "src/github.com/getgauge/"
- mv "gauge-$pkgver" "src/github.com/getgauge/gauge"
+ mkdir -p "github.com/getgauge/"
+ mv "gauge-$pkgver" "github.com/getgauge/gauge"
}
build() {
- export GOPATH="${srcdir}"
-
- cd "${srcdir}/src/github.com/getgauge/gauge"
-
- go run build/make.go
+ export GOPATH="${startdir}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-trimpath"
+
+ cd "${srcdir}/${_gauge_path}/"
+ go run build/make.go
}
package() {
- cd "${srcdir}/src/github.com/getgauge/gauge"
-
- go run build/make.go --install --prefix="$pkgdir/usr"
+ cd "${srcdir}/${_gauge_path}"
+ go run build/make.go --install --prefix="${pkgdir}/usr"
}
-