summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD36
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd0955e78960
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = getgauge
+ pkgdesc = Light weight cross-platform test automation tool for authoring test cases in the business language.
+ pkgver = 0.9.4
+ pkgrel = 1
+ url = https://getgauge.io
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = go
+ makedepends = godep
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/getgauge/gauge/archive/v0.9.4.tar.gz
+ sha256sums = b517997c5675b6997cb0707ab81b86053a10937b186458a96b65c3ec64caffc6
+
+pkgname = getgauge
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..241e560df690
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f7050c9694d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniel Biehl dbiehl@live.de
+
+pkgname=getgauge
+pkgver=0.9.4
+pkgrel=1
+pkgdesc="Light weight cross-platform test automation tool for authoring test cases in the business language."
+arch=('x86_64' 'i686')
+url="https://getgauge.io"
+license=('GPL3')
+makedepends=('go' "godep")
+
+source=("https://github.com/getgauge/gauge/archive/v$pkgver.tar.gz")
+sha256sums=('b517997c5675b6997cb0707ab81b86053a10937b186458a96b65c3ec64caffc6')
+_gourl="/github.com/getgauge/gauge"
+
+prepare() {
+ export GOPATH="${srcdir}"
+
+ cd "$srcdir"
+ mkdir -p "src/github.com/getgauge/"
+ mv "gauge-$pkgver" "src/github.com/getgauge/gauge"
+}
+
+build() {
+ cd "${srcdir}/src/github.com/getgauge/gauge"
+
+ godep restore
+ go run build/make.go
+}
+
+package() {
+ cd "${srcdir}/src/github.com/getgauge/gauge"
+
+ go run build/make.go --install --prefix="$pkgdir/usr"
+}
+