summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d94d7357d90e..0b833acf30f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = getgauge
pkgdesc = Light weight cross-platform test automation tool for authoring test cases in the business language.
pkgver = 1.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://getgauge.io
arch = x86_64
arch = i686
license = GPL3
makedepends = go
- makedepends = godep
source = https://github.com/getgauge/gauge/archive/v1.0.3.tar.gz
sha256sums = c0092f40940469853ef0810b6ae388b405b60c7a40dc5585af841652da40cee8
diff --git a/PKGBUILD b/PKGBUILD
index 672a604238bb..afe3f82fcfdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,29 @@
pkgname=getgauge
pkgver=1.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Light weight cross-platform test automation tool for authoring test cases in the business language."
arch=('x86_64' 'i686')
url="https://getgauge.io"
license=('GPL3')
-makedepends=('go' "godep")
+makedepends=('go')
source=("https://github.com/getgauge/gauge/archive/v$pkgver.tar.gz")
sha256sums=('c0092f40940469853ef0810b6ae388b405b60c7a40dc5585af841652da40cee8')
_gourl="/github.com/getgauge/gauge"
-prepare() {
- export GOPATH="${srcdir}"
-
+prepare() {
cd "$srcdir"
mkdir -p "src/github.com/getgauge/"
mv "gauge-$pkgver" "src/github.com/getgauge/gauge"
}
-build() {
+build() {
+ export GOPATH="${srcdir}"
+
cd "${srcdir}/src/github.com/getgauge/gauge"
-
- #godep restore
+
go run build/make.go
}