summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19b39b600805..bb354d158175 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = gfxbench
pkgdesc = Unified graphics benchmark based on DXBenchmark (DirectX) and GLBenchmark (OpenGL ES)
pkgver = 4.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://gfxbench.com/
arch = i686
arch = x86_64
license = custom
depends = libpng12
- source_i686 = gfxbench_gl-linux-qt-4.0.0+community.sh::http://gfxbench.com/download/gfxbench_gl-linux-qt-4.0.0+community_32bit.sh
+ source_i686 = http://gfxbench.com/download/gfxbench_gl-linux-qt-4.0.0+community_32bit.sh
md5sums_i686 = 9eccb959962efda21f94d5bb301ece5c
- source_x86_64 = gfxbench_gl-linux-qt-4.0.0+community.sh::http://gfxbench.com/download/gfxbench_gl-linux-qt-4.0.0+community_64bit.sh
+ source_x86_64 = http://gfxbench.com/download/gfxbench_gl-linux-qt-4.0.0+community_64bit.sh
md5sums_x86_64 = 9ec770568944857158b05238b8593405
pkgname = gfxbench
diff --git a/PKGBUILD b/PKGBUILD
index dd9eb1d06c91..514773021622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gfxbench
pkgver=4.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Unified graphics benchmark based on DXBenchmark (DirectX) and GLBenchmark (OpenGL ES)"
url='https://gfxbench.com/'
arch=('i686' 'x86_64')
@@ -15,17 +15,19 @@ md5sums_i686=( '9eccb959962efda21f94d5bb301ece5c')
md5sums_x86_64=('9ec770568944857158b05238b8593405')
package() {
- cd "$srcdir"
+ cd "${srcdir}"
- install -dm755 "$pkgdir/opt/${pkgname}/"
- sh "${_basename}.sh" \
+ install -dm755 "${pkgdir}"/opt/"${pkgname}"
+ sh "${_basename}".sh \
--skip-license \
- --prefix="$pkgdir/opt/${pkgname}/"
+ --prefix="${pkgdir}"/opt/"${pkgname}"
- install -dm755 "$pkgdir/usr/bin/"
- ln -s "/opt/${pkgname}/gfxbench_gl" "$pkgdir/usr/bin/$pkgname"
+ install -dm755 "${pkgdir}"/usr/bin
+ ln -s /opt/"${pkgname}"/gfxbench_gl "${pkgdir}"/usr/bin/"${pkgname}"
- install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
- awk '/END USER LICENSE AGREEMENT/,/____cpack__here_doc____/' "${_basename}.sh" |
- head -n-1 > "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -dm755 "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ ln -s /opt/"${pkgname}"/copyright "${pkgdir}"/usr/share/licenses/"${pkgname}"
+
+ # Fix path
+ sed -i "s#${pkgdir}##" "${pkgdir}"/opt/"${pkgname}"/gfxbench_gl.desktop
}