summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f653c22510b..66e9fc04eb34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Aug 29 16:22:00 UTC 2021
pkgbase = ghdl-mcode-git
pkgdesc = VHDL simulator - mcode back-end
- pkgver = 2.0.0dev.r6542.gbbdff59e4
+ pkgver = 2.0.0dev.r6945.gaee3585af
pkgrel = 1
url = https://github.com/ghdl/ghdl
arch = x86_64
@@ -12,15 +10,14 @@ pkgbase = ghdl-mcode-git
checkdepends = python-pytest
checkdepends = python-pydecor
checkdepends = python-pyvhdlmodel>=0.12
- checkdepends = python-pymetaclasses
+ checkdepends = python-pytooling
checkdepends = python-pyattributes
- checkdepends = python-pyterminalui
+ checkdepends = python-pytooling-terminalui
makedepends = git
depends = gcc-ada
- optdepends = python-pydecor: for pyGHDL
- optdepends = python-pyvhdlmodel: for pyGHDL.dom
- provides = ghdl=2.0.0dev.r6542.gbbdff59e4
- provides = ghdl-git=2.0.0dev.r6542.gbbdff59e4
+ optdepends = python-pyghdl: python bindings and utilities
+ provides = ghdl=2.0.0dev.r6945.gaee3585af
+ provides = ghdl-git=2.0.0dev.r6945.gaee3585af
conflicts = ghdl
conflicts = ghdl-gcc-git
conflicts = ghdl-llvm-git
@@ -28,4 +25,3 @@ pkgbase = ghdl-mcode-git
sha256sums = SKIP
pkgname = ghdl-mcode-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2445e1dce643..3cb1bba7397c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrien Prost-Boucle <adrien.prost-boucle@laposte.net>
pkgname=ghdl-mcode-git
-pkgver=2.0.0dev.r6542.gbbdff59e4
+pkgver=2.0.0dev.r6945.gaee3585af
pkgrel=1
arch=('x86_64' 'i686' 'pentium4')
pkgdesc='VHDL simulator - mcode back-end'
@@ -14,19 +14,16 @@ makedepends=('git')
depends=('gcc-ada')
checkdepends=(
'python-pytest' 'python-pydecor' 'python-pyvhdlmodel>=0.12'
- 'python-pymetaclasses' 'python-pyattributes' 'python-pyterminalui'
+ 'python-pytooling' 'python-pyattributes' 'python-pytooling-terminalui'
)
optdepends=(
- 'python-pydecor: for pyGHDL'
- 'python-pyvhdlmodel: for pyGHDL.dom'
+ 'python-pyghdl: python bindings and utilities'
)
source=(
"ghdl::git://github.com/ghdl/ghdl.git"
)
-sha256sums=(
- 'SKIP'
-)
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/ghdl"