summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD42
-rw-r--r--ghost-desktop.install7
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33b3f4895f62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Sat Nov 5 11:24:43 UTC 2016
+pkgbase = ghost-desktop
+ pkgdesc = Ghost Desktop is a beautiful desktop application that allows you to easily manage multiple Ghost blogs and work without distractions.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/TryGhost/Ghost-Desktop
+ install = ghost-desktop.install
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = gtk2
+ depends = libgnome-keyring
+ depends = gnome-keyring
+ depends = desktop-file-utils
+ depends = python2
+ depends = gconf
+ depends = nodejs
+ depends = libnotify
+ depends = libxtst
+ depends = nss
+ depends = alsa-lib
+ depends = libxss
+ source = https://github.com/TryGhost/Ghost-Desktop/releases/download/v1.0.0/ghost-desktop-1.0.0-debian.deb
+ md5sums = 68eb1191c7f98121d9736fdc66900055
+
+pkgname = ghost-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09802248bac8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Guillaume Hayot <postblue@postblue.info>
+pkgname=ghost-desktop
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Ghost Desktop is a beautiful desktop application that allows you to easily manage multiple Ghost blogs and work without distractions."
+arch=('x86_64' 'i686')
+url="https://github.com/TryGhost/Ghost-Desktop"
+license=('MIT')
+depends=('gtk2' 'libgnome-keyring' 'gnome-keyring' 'desktop-file-utils' 'python2' 'gconf' 'nodejs' 'libnotify' 'libxtst' 'nss' 'alsa-lib' 'libxss')
+source=(https://github.com/TryGhost/Ghost-Desktop/releases/download/v${pkgver}/${pkgname}-${pkgver}-debian.deb)
+install=${pkgname}.install
+md5sums=('68eb1191c7f98121d9736fdc66900055')
+package() {
+ msg2 "Extracting data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "${pkgdir}/"
+
+ cd "${pkgdir}"
+ find -name '*.py' -exec sed -i 's|^#!/usr/bin/env python\s*$|#!/usr/bin/env python2|' {} \;
+ find -name '*.py' -exec sed -i 's|^#!/usr/bin/python\s*$|#!/usr/bin/python2|' {} \;
+
+ find "${pkgdir}"/usr -type f -exec chmod 644 {} \;
+ find "${pkgdir}"/usr/bin -type f -exec chmod 755 {} \;
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} \;
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # Cleaning up package
+ rm -rf "${pkgdir}/usr/bin/Ghost"
+ rm -rf "${pkgdir}/usr/shar/lintian"
+
+ # Change paths to match pkgname
+ mv "${pkgdir}/usr/share/Ghost" "${pkgdir}/usr/share/${pkgname}"
+ mv "${pkgdir}/usr/share/applications/Ghost.desktop" "${pkgdir}/usr/share/${pkgname}/${pkgname}.desktop"
+ sed -i "s/=Ghost/=${pkgname}/" "${pkgdir}/usr/share/${pkgname}/${pkgname}.desktop"
+ mv "${pkgdir}/usr/share/doc/Ghost" "${pkgdir}/usr/share/doc/${pkgname}"
+ mv "${pkgdir}/usr/share/pixmaps/Ghost.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ # Fix bin
+ chmod +x ${pkgdir}/usr/share/${pkgname}/Ghost
+ ln -s /usr/share/${pkgname}/Ghost "${pkgdir}/usr/bin/${pkgname}"
+ ln -s /usr/share/${pkgname}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/ghost-desktop.install b/ghost-desktop.install
new file mode 100644
index 000000000000..6f0c3704fe9c
--- /dev/null
+++ b/ghost-desktop.install
@@ -0,0 +1,7 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}