summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD48
-rw-r--r--giana-fs.desktop9
-rw-r--r--giana.desktop2
-rw-r--r--giana.install16
-rw-r--r--giana.sh2
6 files changed, 43 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0f896452daa..d2e8a3edaae4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,6 @@ pkgbase = giana
license = custom: Freeware
depends = sdl_mixer
depends = zlib
- depends = desktop-file-utils
depends = glut
depends = glu
optdepends = libmodplug: better music decoder
@@ -17,15 +16,11 @@ pkgbase = giana
source = http://www.gianas-return.de/gr-v1001-ubuntu.zip
source = giana.sh
source = giana.desktop
- source = giana.install
- md5sums = 9b6f8459ecd2483f0756e170908c780d
- md5sums = 379904ec4b97453eb08dea10962b45e2
- md5sums = 602c3f7fc8440250bd1136586f93f7c5
- md5sums = 4535be161d68a7a13448eeb8abf99d15
+ source = giana-fs.desktop
sha256sums = cf932707776c25444cb9ff9feb91489886efdc3764aa6aeeb53845f7c1816970
- sha256sums = f4e95c46847c2435870a920ea94a9674f8a28fd9ea14d81f6d8c4be9d2b3d85b
- sha256sums = 9aa9cd5a33c16cc529aaff71b040f055416fa25320925b344937dbe3909225cc
- sha256sums = b454a6cc67780d483beb00fa7b015a9b8ebca3fd6dbfc472a79719b7716e9f7c
+ sha256sums = e42996d0a09c6384fe0af413f8737256fd79f5d1094b1074018e4404a68246da
+ sha256sums = ea2452f45c2edeb9acac12294ff759e465e010fa997cc2fdf9d2ab57af76a0d9
+ sha256sums = 80aa0cd19c742199c69b7c1778f28c8f75aa6646c2b3a26ae6eed608b2d6a7a4
pkgname = giana
diff --git a/PKGBUILD b/PKGBUILD
index edeb067d443d..ecfdf4127629 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,50 @@
-# Maintainer: carstene1ns <arch carsten-teibes de>
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
# Contributor: megadriver <megadriver at gmx dot com>
pkgname=giana
pkgver=1.001
+_pkgver=${pkgver//./}
pkgrel=3
pkgdesc="Giana's Return, unofficial sequel to the (in)famous Mario clone Great Giana Sisters"
arch=('i686' 'x86_64')
url="http://www.gianas-return.de"
license=('custom: Freeware')
-depends=('sdl_mixer' 'zlib' 'desktop-file-utils' 'glut' 'glu')
+depends=('sdl_mixer' 'zlib' 'glut' 'glu')
optdepends=('libmodplug: better music decoder')
install=$pkgname.install
options=(!strip)
-source=("http://www.gianas-return.de/gr-v1001-ubuntu.zip"
+source=("http://www.gianas-return.de/gr-v$_pkgver-ubuntu.zip"
"$pkgname.sh"
"$pkgname.desktop"
- "$pkgname.install")
-md5sums=('9b6f8459ecd2483f0756e170908c780d'
- '379904ec4b97453eb08dea10962b45e2'
- '602c3f7fc8440250bd1136586f93f7c5'
- '4535be161d68a7a13448eeb8abf99d15')
+ "$pkgname-fs.desktop")
sha256sums=('cf932707776c25444cb9ff9feb91489886efdc3764aa6aeeb53845f7c1816970'
- 'f4e95c46847c2435870a920ea94a9674f8a28fd9ea14d81f6d8c4be9d2b3d85b'
- '9aa9cd5a33c16cc529aaff71b040f055416fa25320925b344937dbe3909225cc'
- 'b454a6cc67780d483beb00fa7b015a9b8ebca3fd6dbfc472a79719b7716e9f7c')
+ 'e42996d0a09c6384fe0af413f8737256fd79f5d1094b1074018e4404a68246da'
+ 'ea2452f45c2edeb9acac12294ff759e465e010fa997cc2fdf9d2ab57af76a0d9'
+ '80aa0cd19c742199c69b7c1778f28c8f75aa6646c2b3a26ae6eed608b2d6a7a4')
package() {
- cd "$srcdir"
+ # create folders
+ install -d "$pkgdir"/{opt/$pkgname/data,usr/share/{doc,licenses}/$pkgname}
# install architecture dependent executeable
case $CARCH in
- "i686")
- install -Dm755 ${pkgname}_ubuntu32 $pkgdir/opt/$pkgname/$pkgname;;
- "x86_64")
- install -Dm755 ${pkgname}_ubuntu64 $pkgdir/opt/$pkgname/$pkgname;;
+ i686)
+ install -m755 ${pkgname}_ubuntu32 "$pkgdir"/opt/$pkgname/$pkgname;;
+ x86_64)
+ install -m755 ${pkgname}_ubuntu64 "$pkgdir"/opt/$pkgname/$pkgname;;
esac
- # install data files
- cp -r data $pkgdir/opt/$pkgname/
- mkdir -p $pkgdir/usr/share/doc/giana
- install -m644 *.txt $pkgdir/usr/share/doc/giana/
+ # install data files and create license file
+ install -m644 data/*.zda "$pkgdir"/opt/$pkgname/data
+ install -m644 *.txt "$pkgdir"/usr/share/doc/$pkgname
+ tail -n +45 readme.txt | head -n 8 > "$pkgdir"/usr/share/licenses/$pkgname/FREEWARE
# set group permission of folder, so we can save highscores and config later
- chgrp games $pkgdir/opt/$pkgname
- chmod g+w $pkgdir/opt/$pkgname
+ chgrp games "$pkgdir"/opt/$pkgname
+ chmod g+w "$pkgdir"/opt/$pkgname
# install launcher and desktop file
- install -Dm755 $pkgname.sh $pkgdir/usr/bin/$pkgname
- install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
- install -Dm644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 $pkgname.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
}
diff --git a/giana-fs.desktop b/giana-fs.desktop
new file mode 100644
index 000000000000..1f6dc8c2814d
--- /dev/null
+++ b/giana-fs.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Giana's Return (Fullscreen)
+Comment=Jump and run platformer (Mario Bros. Clone)
+Exec=giana -fs
+Icon=giana
+Terminal=false
+Categories=Game;
diff --git a/giana.desktop b/giana.desktop
index ed8e10c240d2..91c10440d37b 100644
--- a/giana.desktop
+++ b/giana.desktop
@@ -3,7 +3,7 @@ Type=Application
Version=1.0
Name=Giana's Return
Comment=Jump and run platformer (Mario Bros. Clone)
-Exec=giana -fs
+Exec=giana -ogl
Icon=giana
Terminal=false
Categories=Game;
diff --git a/giana.install b/giana.install
index 8f391adc3c40..c46386609d2c 100644
--- a/giana.install
+++ b/giana.install
@@ -2,28 +2,20 @@
post_install() {
# display some info
echo "You must be a member of the games group for the save functionality to work."
- echo "Try 'giana -fs' for fullscreen mode (default for .desktop file)"
- echo "or try 'giana -ogl' (opengl 640x480) or 'giana -hd' (opengl 1360x768)"
- echo "For options see also the .txt files in /usr/share/doc/giana/"
-
- # apply updates for our .desktop file
- update-desktop-database -q
+ echo "For command line options see /usr/share/doc/giana/options.txt"
# allow saving of highscore and config (doing it here, so the do not get deleted on update)
touch /opt/giana/{giana.cfg,hiscores.dat,passwd.dat}
chgrp games /opt/giana/{giana.cfg,hiscores.dat,passwd.dat}
chmod g+w /opt/giana/{giana.cfg,hiscores.dat,passwd.dat}
}
+
post_upgrade() {
- # apply updates for our .desktop file
- update-desktop-database -q
+ post_install
}
post_remove() {
if [ -d /opt/giana ]; then
- echo "You may delete /opt/giana if you don't want to preserve settings and highscores."
+ echo "You may delete /opt/giana if you do not want to preserve settings and highscores."
fi
-
- # apply updates for our .desktop file
- update-desktop-database -q
}
diff --git a/giana.sh b/giana.sh
index 8eb49a2b16a9..95c707016820 100644
--- a/giana.sh
+++ b/giana.sh
@@ -1,5 +1,7 @@
#!/bin/sh
cd /opt/giana
+
./giana "$@"
+
cd - &>/dev/null