summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
-rw-r--r--giggle.install17
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6291ace6222
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = giggle-git
+ pkgdesc = A graphical frontend for the git directory tracker - git checkout
+ pkgver = 0.5.r289.g44490f7
+ pkgrel = 1
+ url = http://live.gnome.org/giggle
+ install = giggle.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = git
+ depends = gtksourceview3
+ depends = vte3
+ provides = giggle
+ conflicts = giggle
+ options = !libtool
+ source = git://git.gnome.org/giggle
+ sha256sums = SKIP
+
+pkgname = giggle-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2735bcb15fbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+#Maintainer: Christian Hesse <mail@eworm.de>
+#Contributor: Gergely Imreh <imrehg(at)gmail(dot)com>
+
+pkgname=giggle-git
+pkgver=0.5.r289.g44490f7
+pkgrel=1
+pkgdesc='A graphical frontend for the git directory tracker - git checkout'
+arch=('i686' 'x86_64')
+url='http://live.gnome.org/giggle'
+license=('GPL')
+depends=('git' 'gtksourceview3' 'vte3')
+options=(!libtool)
+install=giggle.install
+provides=('giggle')
+conflicts=('giggle')
+source=('git://git.gnome.org/giggle')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd giggle/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd giggle/
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd giggle/
+
+ make prefix=${pkgdir}/usr install
+ # this file shouldn't be here
+ rm ${pkgdir}/usr/share/icons/hicolor/icon-theme.cache
+}
+
diff --git a/giggle.install b/giggle.install
new file mode 100644
index 000000000000..a50d2a8dfb68
--- /dev/null
+++ b/giggle.install
@@ -0,0 +1,17 @@
+post_install() {
+ gtk-update-icon-cache -f -t -q /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*