summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD42
-rw-r--r--gis-weather.desktop8
4 files changed, 50 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 054c574e2bb1..413d63a69632 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = gis-weather
pkgdesc = Customizable weather widget
- pkgver = 0.8.4.1
+ pkgver = 0.8.4.17
pkgrel = 1
- url = http://sourceforge.net/projects/gis-weather
- arch = i686
- arch = x86_64
- license = GPLv3
+ url = https://github.com/RingOV/gis-weather
+ arch = any
+ license = GPL3
depends = gtk3
+ depends = libappindicator-gtk3
depends = python
- depends = python-gobject
depends = python-cairo
+ depends = python-distro
+ depends = python-gobject
optdepends = librsvg
conflicts = gis-weather-git
- source = http://sourceforge.net/projects/gis-weather/files/gis-weather/0.8.4.1/gis-weather_0.8.4.1_all.deb/download
- sha256sums = 5e2856f8201942959d790a9ebe8e790e71d71554c6984c990254088e23693fe3
+ source = https://github.com/RingOV/gis-weather/archive/refs/tags/v0.8.4.17.zip
+ source = gis-weather.desktop
+ sha256sums = a50f5604a3ca4ee90181c96adafdfc40e95a8ae542afde8bfb709aeef89134d2
+ sha256sums = e5bd1f85c730fcf4a5cc2618b2cb3184597443188b12eb2071540468418575e3
pkgname = gis-weather
-
diff --git a/.gitignore b/.gitignore
index 6effdd9ebed8..14a24f0036da 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ download
pkg/
src/
*.xz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 6d43d8d8360e..e76ffc3574ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,43 @@
# Maintainer: Haron Prime (Haron_Prime) <haron.prime@gmx.com>
pkgname=gis-weather
-pkgver=0.8.4.1
+pkgver=0.8.4.17
pkgrel=1
pkgdesc="Customizable weather widget"
-arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/gis-weather"
-license=('GPLv3')
+arch=('any')
+url="https://github.com/RingOV/gis-weather"
+license=('GPL3')
groups=()
-depends=('gtk3' 'python' 'python-gobject' 'python-cairo')
+depends=('gtk3' 'libappindicator-gtk3' 'python' 'python-cairo' 'python-distro' 'python-gobject')
optdepends=('librsvg')
provides=()
conflicts=('gis-weather-git')
-source=(${url}/files/${pkgname}/${pkgver}/${pkgname}_${pkgver}_all.deb/download)
-sha256sums=('5e2856f8201942959d790a9ebe8e790e71d71554c6984c990254088e23693fe3')
+source=(
+ "https://github.com/RingOV/${pkgname}/archive/refs/tags/v${pkgver}.zip"
+ "gis-weather.desktop"
+)
+sha256sums=(
+ 'a50f5604a3ca4ee90181c96adafdfc40e95a8ae542afde8bfb709aeef89134d2'
+ 'e5bd1f85c730fcf4a5cc2618b2cb3184597443188b12eb2071540468418575e3'
+)
package() {
- cd "$srcdir"
- tar -xf data.tar.xz -C "${pkgdir}"
- echo "aur" > "${pkgdir}/usr/share/${pkgname}/package"
- chmod -R 777 "${pkgdir}"/usr/share/${pkgname}
- mkdir -p $pkgdir/usr/bin
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # symlink executable
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s '/usr/share/gis-weather/gis-weather.py' "$pkgdir/usr/bin/gis-weather"
+
+ # install files
+ install -vDm0755 'gis-weather.py' -t "$pkgdir/usr/share/gis-weather"
+ install -vDm0644 'icon.png' -t "$pkgdir/usr/share/pixmaps"
+ install -vDm0644 "$srcdir/gis-weather.desktop" -t "$pkgdir/usr/share/applications"
+
+ install -vDm0644 {'icon.png','README.md'} -t "$pkgdir/usr/share/gis-weather"
+
+ #install folders
+ for _f in 'dialogs' 'i18n' 'po' 'services' 'themes' 'utils' ; do
+ cp --reflink=auto -r "$_f" "$pkgdir/usr/share/gis-weather/"
+ done
}
diff --git a/gis-weather.desktop b/gis-weather.desktop
new file mode 100644
index 000000000000..2b8299c66d28
--- /dev/null
+++ b/gis-weather.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Gis Weather
+Comment=Weather widget
+Categories=GNOME;Utility;
+Exec=/usr/bin/gis-weather
+Icon=gis-weather
+Terminal=false
+Type=Application