summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d97abb6866af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Aug 17 16:30:38 UTC 2018
+pkgbase = git-bug-git
+ pkgdesc = Distributed bug tracker embedded in Git (git)
+ pkgver = 0.2.0+1+gc974cc0
+ pkgrel = 1
+ url = https://github.com/MichaelMure/git-bug
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = go
+ provides = git-bug
+ conflicts = git-bug
+ conflicts = git-bug-bin
+ source = git+https://github.com/MichaelMure/git-bug
+ sha512sums = SKIP
+
+pkgname = git-bug-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65e17af0a857
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=git-bug-git
+pkgver=0.2.0+1+gc974cc0
+pkgrel=1
+pkgdesc='Distributed bug tracker embedded in Git (git)'
+arch=(i686 x86_64)
+url=https://github.com/MichaelMure/git-bug
+license=(GPL3)
+makedepends=(go)
+provides=(git-bug)
+conflicts=(git-bug git-bug-bin)
+source=(git+$url)
+sha512sums=(SKIP)
+
+pkgver() {
+ cd git-bug
+ git describe --tags | sed 's/v//;s/-/+/g'
+}
+
+build() {
+ cd git-bug
+ GOPATH="$srcdir"/git-bug go get -v -x github.com/MichaelMure/git-bug
+}
+
+package() {
+ cd git-bug
+ install -D bin/git-bug "$pkgdir"/usr/bin/git-bug
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/git-bug
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/git-bug
+}