summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4820a491508
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = git-bzr-kfish-git
+ pkgdesc = a bidirectional git - bazaar gateway
+ pkgver = 1.1.r62.gf798106
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/kfish/git-bzr
+ arch = any
+ license = GPL
+ depends = git
+ depends = bzr
+ depends = bzr-fastimport
+ source = git-bzr-kfish-git::git+https://github.com/kfish/git-bzr.git
+ md5sums = SKIP
+
+pkgname = git-bzr-kfish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a5262ee66f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=git-bzr-kfish-git
+pkgver=1.1.r62.gf798106
+pkgrel=1
+epoch=1
+pkgdesc="a bidirectional git - bazaar gateway"
+arch=('any')
+url="https://github.com/kfish/git-bzr"
+license=('GPL')
+depends=('git' 'bzr' 'bzr-fastimport')
+source=("$pkgname::git+https://github.com/kfish/git-bzr.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags|sed -r 's,^[a-zA-Z]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd $pkgname
+ mkdir -p "${pkgdir}/usr/bin/"
+ install git-bzr "${pkgdir}/usr/bin/"
+}