summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3e8bf482357..56e00cca5593 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = git-caja-icons-py2
pkgdesc = A Caja extension to overlay icons on files in git repositories, Python 2 version
pkgver = 1.1.1
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/chrisjbillington/git_nautilus_icons
arch = x86_64
arch = i686
@@ -11,8 +11,8 @@ pkgbase = git-caja-icons-py2
depends = python2-caja
provides = git-caja-icons-py2
conflicts = git-caja-icons-py2
- source = https://github.com/chrisjbillington/git_nautilus_icons/archive/1.1.1.tar.gz
- sha512sums = c5e439b1a91b183b6fe3d52ddeae796c2339a78cf9378736c6eaee336c27b8691be0052f76bf15e9e3901bce2e7a2f7bd3383fa928f252ad50be9a53c0090c7b
+ source = https://files.pythonhosted.org/packages/source/g/git_caja_icons/git_caja_icons-1.1.1.tar.gz
+ sha512sums = 3d3856447edc1fd20dddbb75cafe18aa1eda06fa491ea7b520b425cedcb5fccdf1f6e2322b51214d817492b667e2204fed6a88c5a952b258478fbb7bed7d7f79
pkgname = git-caja-icons-py2
diff --git a/PKGBUILD b/PKGBUILD
index e40f009e4289..128e4ed4bd4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Chris Billington <chrisjbillington@gmail.com>
pkgname=('git-caja-icons-py2')
+_pypi_name=('git_caja_icons')
pkgver=1.1.1
-pkgrel=0
+pkgrel=1
arch=('x86_64' 'i686')
url="https://github.com/chrisjbillington/git_nautilus_icons"
license=('BSD 2-Clause "Simplified"')
@@ -10,16 +11,20 @@ depends=('git-nautilus-icons-common-py2' 'python2-caja')
makedepends=('python2-setuptools')
provides=('git-caja-icons-py2')
conflicts=('git-caja-icons-py2')
-source=("https://github.com/chrisjbillington/git_nautilus_icons/archive/${pkgver}.tar.gz")
-sha512sums=('c5e439b1a91b183b6fe3d52ddeae796c2339a78cf9378736c6eaee336c27b8691be0052f76bf15e9e3901bce2e7a2f7bd3383fa928f252ad50be9a53c0090c7b')
+source=("https://files.pythonhosted.org/packages/source/${_pypi_name::1}/$_pypi_name/$_pypi_name-$pkgver.tar.gz")
+sha512sums=('3d3856447edc1fd20dddbb75cafe18aa1eda06fa491ea7b520b425cedcb5fccdf1f6e2322b51214d817492b667e2204fed6a88c5a952b258478fbb7bed7d7f79')
build() {
- cd "${srcdir}/git_nautilus_icons-${pkgver}/git_caja_icons"
+ cd "${srcdir}/${_pypi_name}-${pkgver}"
python2 setup.py build
}
package() {
- cd "${srcdir}/git_nautilus_icons-${pkgver}/git_caja_icons"
+ cd "${srcdir}/${_pypi_name}-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-} \ No newline at end of file
+
+ # compile Python bytecode for modules outside of site-packages:
+ python2 -m compileall -d / "${pkgdir}"/usr/{lib,share}
+ python2 -O -m compileall -d / "${pkgdir}"/usr/{lib,share}
+}