summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3e8bf482357
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = git-caja-icons-py2
+ pkgdesc = A Caja extension to overlay icons on files in git repositories, Python 2 version
+ pkgver = 1.1.1
+ pkgrel = 0
+ url = https://github.com/chrisjbillington/git_nautilus_icons
+ arch = x86_64
+ arch = i686
+ license = BSD 2-Clause "Simplified"
+ makedepends = python2-setuptools
+ depends = git-nautilus-icons-common-py2
+ depends = python2-caja
+ provides = git-caja-icons-py2
+ conflicts = git-caja-icons-py2
+ source = https://github.com/chrisjbillington/git_nautilus_icons/archive/1.1.1.tar.gz
+ sha512sums = c5e439b1a91b183b6fe3d52ddeae796c2339a78cf9378736c6eaee336c27b8691be0052f76bf15e9e3901bce2e7a2f7bd3383fa928f252ad50be9a53c0090c7b
+
+pkgname = git-caja-icons-py2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e40f009e4289
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Chris Billington <chrisjbillington@gmail.com>
+pkgname=('git-caja-icons-py2')
+pkgver=1.1.1
+pkgrel=0
+arch=('x86_64' 'i686')
+url="https://github.com/chrisjbillington/git_nautilus_icons"
+license=('BSD 2-Clause "Simplified"')
+pkgdesc="A Caja extension to overlay icons on files in git repositories, Python 2 version"
+depends=('git-nautilus-icons-common-py2' 'python2-caja')
+makedepends=('python2-setuptools')
+provides=('git-caja-icons-py2')
+conflicts=('git-caja-icons-py2')
+source=("https://github.com/chrisjbillington/git_nautilus_icons/archive/${pkgver}.tar.gz")
+sha512sums=('c5e439b1a91b183b6fe3d52ddeae796c2339a78cf9378736c6eaee336c27b8691be0052f76bf15e9e3901bce2e7a2f7bd3383fa928f252ad50be9a53c0090c7b')
+
+build() {
+ cd "${srcdir}/git_nautilus_icons-${pkgver}/git_caja_icons"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/git_nautilus_icons-${pkgver}/git_caja_icons"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file