summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore1
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD38
-rw-r--r--git-credential-manager-core.install16
5 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f637d1ee296
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = git-credential-manager-core-bin
+ pkgdesc = Secure, cross-platform Git credential storage with authentication to GitHub, Azure Repos, and other popular Git hosting services.
+ pkgver = 2.0.394
+ pkgrel = 1
+ url = https://github.com/microsoft/Git-Credential-Manager-Core
+ install = git-credential-manager-core.install
+ arch = x86_64
+ license = MIT
+ depends = zlib
+ depends = krb5
+ optdepends = kwallet: For storing credentials
+ optdepends = gnome-keyring: For storing credentials
+ optdepends = gpg: For storing credentials in a gpg file
+ optdepends = pass: For storing credentials in a gpg file
+ provides = git-credential-manager-core
+ conflicts = git-credential-manager-core
+ options = !strip
+ source = https://github.com/microsoft/Git-Credential-Manager-Core/releases/download/v2.0.394-beta/gcmcore-linux_amd64.2.0.394.50751.tar.gz
+ source = git-credential-manager-core.install
+ source = LICENSE
+ sha256sums = a261a5dcfd8563c8edd498717e2a6f4ae70ec3a2fb3e39560edbba4f129ee865
+ sha256sums = 28e0fe2c913d89b226274dfc8ec4ff7fb9bf8c11cea920608043521daff76081
+ sha256sums = 30147347d5ce41662672ea2be7b158ae0e014398b97a148dd07bfd46c5166292
+
+pkgname = git-credential-manager-core-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f6570c989e87
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Git Credential Manager Core
+Copyright (c) Microsoft Corporation. All rights reserved.
+
+MIT License
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00e41bdaaf4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Gabriel Guldner <gabriel at guldner.eu>
+pkgname=git-credential-manager-core-bin
+_pkgname=git-credential-manager-core
+pkgver=2.0.394
+_pkgver=2.0.394-beta
+_build=50751
+pkgrel=1
+pkgdesc="Secure, cross-platform Git credential storage with authentication to GitHub, Azure Repos, and other popular Git hosting services."
+arch=('x86_64')
+url="https://github.com/microsoft/Git-Credential-Manager-Core"
+license=('MIT')
+depends=('zlib' 'krb5')
+optdepends=('kwallet: For storing credentials'
+ 'gnome-keyring: For storing credentials'
+ 'gpg: For storing credentials in a gpg file'
+ 'pass: For storing credentials in a gpg file' )
+provides=($_pkgname)
+conflicts=($_pkgname)
+install=$_pkgname.install
+changelog=
+options=('!strip')
+source=("https://github.com/microsoft/Git-Credential-Manager-Core/releases/download/v$_pkgver/gcmcore-linux_amd64.$pkgver.$_build.tar.gz"
+ "$_pkgname.install"
+ 'LICENSE')
+sha256sums=('a261a5dcfd8563c8edd498717e2a6f4ae70ec3a2fb3e39560edbba4f129ee865'
+ '28e0fe2c913d89b226274dfc8ec4ff7fb9bf8c11cea920608043521daff76081'
+ '30147347d5ce41662672ea2be7b158ae0e014398b97a148dd07bfd46c5166292')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 -o0 -g0 git-credential-manager-core "$pkgdir/usr/bin/git-credential-manager-core"
+ install -Dm644 -o0 -g0 LICENSE "$pkgdir/usr/share/licenses/git-credential-manager-core-bin/LICENSE"
+}
diff --git a/git-credential-manager-core.install b/git-credential-manager-core.install
new file mode 100644
index 000000000000..6481f2230d24
--- /dev/null
+++ b/git-credential-manager-core.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo ""
+ echo "Run the folloing to configure the application:"
+ echo "git-credential-manager-core configure"
+ echo ""
+ echo "And see the following url for backend configuration:"
+ echo "https://github.com/microsoft/Git-Credential-Manager-Core/blob/master/docs/linuxcredstores.md"
+ echo ""
+}
+
+post_remove() {
+ echo ""
+ echo "Remove the credential helper from the git configuration:"
+ echo "git-credential-manager-core unconfigure"
+ echo ""
+}