summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f068f529089..2ed3ce1ef186 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,11 +35,15 @@ prepare() {
build() {
cd "$_name-$pkgver"
+ # git2 cannot be built with current nightly due to a regression; for ref.:
+ # https://github.com/rust-lang/rust/issues/85574
+ RUSTUP_TOOLCHAIN=stable \
cargo build --release --locked --target-dir ./target
}
check() {
cd "$_name-$pkgver"
+ RUSTUP_TOOLCHAIN=stable \
cargo test --release --locked --target-dir ./target
}