summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--git-interactive-rebase-tool.install13
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f70c530116a..8f47b401ea09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = git-interactive-rebase-tool
pkgdesc = Native cross platform full feature terminal based sequence editor for git interactive rebase. Written in Rust using ncurses.
pkgver = 0.7.0
- pkgrel = 1
- url = https://gitrebasetool.mitmaro.ca/
+ pkgrel = 2
+ url = https://github.com/MitMaro/git-interactive-rebase-tool
+ install = git-interactive-rebase-tool.install
arch = x86_64
license = ISC
makedepends = rust
makedepends = cargo
depends = git
- provides = git-interactive-rebase-tool
- conflicts = git-interactive-rebase-tool
source = git+https://github.com/MitMaro/git-interactive-rebase-tool.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b7ddb448a16b..8fae31196999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,14 @@
pkgname=git-interactive-rebase-tool
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Native cross platform full feature terminal based sequence editor for git interactive rebase. Written in Rust using ncurses.'
arch=('x86_64')
-url='https://gitrebasetool.mitmaro.ca/'
+url='https://github.com/MitMaro/git-interactive-rebase-tool'
license=('ISC')
depends=('git')
makedepends=('rust' 'cargo')
-provides=('git-interactive-rebase-tool')
-conflicts=('git-interactive-rebase-tool')
+install=$pkgname.install
sha256sums=('SKIP')
source=('git+https://github.com/MitMaro/git-interactive-rebase-tool.git')
diff --git a/git-interactive-rebase-tool.install b/git-interactive-rebase-tool.install
new file mode 100644
index 000000000000..ae37701bf6f0
--- /dev/null
+++ b/git-interactive-rebase-tool.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo ""
+ echo "Configure git to use the rebase tool:"
+ echo "git config --global sequence.editor interactive-rebase-tool"
+ echo ""
+}
+
+post_remove() {
+ echo ""
+ echo "You have to remove the tool from the git configuration:"
+ echo "git config --global --unset sequence.editor"
+ echo ""
+}