summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86f4d8bcb84b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = git-pull-request
+ pkgdesc = git command to automatically pull locally github pull requests
+ pkgver = 20140430
+ pkgrel = 1
+ url = http://www.splitbrain.org/blog/2011-06/19-automate_github_pull_requests
+ arch = any
+ license = MIT
+ depends = python2
+ depends = git
+ source = git+https://github.com/splitbrain/git-pull-request.git
+ sha1sums = SKIP
+
+pkgname = git-pull-request
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06a1a8462a95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jörg Thalheim <joerg@higgsboson.tk>
+
+pkgname=git-pull-request
+pkgver=20140430
+pkgrel=1
+pkgdesc="git command to automatically pull locally github pull requests"
+arch=('any')
+url="http://www.splitbrain.org/blog/2011-06/19-automate_github_pull_requests"
+license=('MIT')
+depends=('python2' 'git')
+
+source=("git+https://github.com/splitbrain/git-pull-request.git")
+sha1sums=("SKIP")
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ install -D -m755 git-pull-request $pkgdir/usr/bin/git-pull-request
+}