summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d9f490ad9d5..1c827d08f579 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = git-remote-hg-git
pkgdesc = Transparent bidirectional bridge between Git and Mercurial
pkgver = 0.3.r1.g822c6e4
pkgrel = 1
- epoch = 1
+ epoch = 2
url = https://github.com/felipec/git-remote-hg
arch = any
license = GPL2
@@ -11,7 +11,7 @@ pkgbase = git-remote-hg-git
depends = mercurial
provides = git-remote-hg
conflicts = git-remote-hg
- source = git+https://github.com/felipec/git-remote-hg.git
+ source = git+https://github.com/mnauw/git-remote-hg.git
md5sums = SKIP
pkgname = git-remote-hg-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c78914991c7..8aec06bede24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=git-remote-hg-git
pkgver=0.3.r1.g822c6e4
pkgrel=1
-epoch=1
+epoch=2
provides=("git-remote-hg")
conflicts=("git-remote-hg")
pkgdesc="Transparent bidirectional bridge between Git and Mercurial"
@@ -12,11 +12,12 @@ url="https://github.com/felipec/git-remote-hg"
license=('GPL2')
depends=('git' 'mercurial')
makedepends=('asciidoc')
-source=("git+https://github.com/felipec/git-remote-hg.git")
+source=("git+https://github.com/mnauw/git-remote-hg.git")
md5sums=('SKIP')
pkgver() {
- git --git-dir="$srcdir/git-remote-hg/.git" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
+ cd "${srcdir}/git-remote-hg"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build () {