summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE8
-rwxr-xr-xPKGBUILD25
3 files changed, 30 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df4ca52c69ef..3ed8dbfd98a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Apr 11 07:11:32 UTC 2016
pkgbase = giteye
pkgdesc = A desktop for Git. It works with TeamForge, CloudForge, GitHub and other Git services.
- pkgver = 1.11.0
+ pkgver = 1.12.0
pkgrel = 1
url = http://www.collab.net/giteyeapp
arch = i686
@@ -10,14 +12,18 @@ pkgbase = giteye
depends = git
depends = java-environment
depends = python2
- noextract = *.zip
+ noextract = GitEye-1.11.0-linux.x86_64.zip
+ noextract = GitEye-1.12.0-linux.x86.zip
+ noextract = GitEye-1.12.0-linux.x86_64.zip
options = !strip
source = LICENSE
source = giteye.desktop
- md5sums = 4df23a2c4f45c567feae7665694cd11a
+ md5sums = 29a5e78a36cabce86274d07ea11dd502
md5sums = 3144b18d4ddf6ac166afe374872ce4b4
- source_x86_64 = https://downloads-guests.open.collab.net/files/documents/61/11867/GitEye-1.11.0-linux.x86_64.zip
- md5sums_x86_64 = a6c3e91d9dee12877a27aafabc77f38e
+ source_i686 = https://downloads-guests.open.collab.net/files/documents/61/12536/GitEye-1.12.0-linux.x86.zip
+ md5sums_i686 = 02909e014f13dd29127887b02dbad1eb
+ source_x86_64 = https://downloads-guests.open.collab.net/files/documents/61/12536/GitEye-1.12.0-linux.x86_64.zip
+ md5sums_x86_64 = ecff81dcaee493852ea66a105948af13
pkgname = giteye
diff --git a/LICENSE b/LICENSE
index 8b51399a06bb..02372cf70442 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,9 +1,10 @@
-License - CollabNet GitEye (Linux 32-bit)
+License - CollabNet GitEye (Linux 64-bit)
CollabNet GitEye End User License Agreement
-IMPORTANT: BY ACCESSING, DOWNLOADING OR USING THIS COLLABNET CERTIFIED INTEGRATION SOFTWARE(THE "SOFTWARE") YOU, YOUR EMPLOYEES, AGENTS, AND CONTRACTORS, AND ANY OTHER ENTITY ON WHOSE BEHALF YOU ACCEPT THESE TERMS
+IMPORTANT: BY ACCESSING, DOWNLOADING OR USING THIS COLLABNET CERTIFIED INTEGRATION SOFTWARE(THE "SOFTWARE") YOU, YOUR EMPLOYEES, AGENTS, AND CONTRACTORS, AND ANY OTHER ENTITY ON WHOSE BEHALF YOU ACCEPT
+THESE TERMS
(COLLECTIVELY "YOU", OR "YOUR") ACKNOWLEDGE THAT YOU HAVE READ, UNDERSTOOD AND
AGREE TO BE BOUND BY THE TERMS OF THIS END USER LICENSE AGREEMENT (THE "AGREEMENT").
@@ -21,7 +22,7 @@ AGREE TO BE BOUND BY THE TERMS OF THIS END USER LICENSE AGREEMENT (THE "AGREEMEN
2. Third Party Programs. CollabNet may distribute third party software programs
with the Software that are not part of the Software. These third party software
programs are not required to run the Software, are provided as a convenience to
- You, and are subject to their own license terms (“Third Party License(s)”).
+ You, and are subject to their own license terms ("Third Party License(s)").
Such license terms either accompany the third party software programs or can be
found in the download or source code files. If You do not agree to abide by
the applicable Third Party License terms for the third party software programs,
@@ -90,4 +91,3 @@ AGREE TO BE BOUND BY THE TERMS OF THIS END USER LICENSE AGREEMENT (THE "AGREEMEN
You regarding this Agreement or the Software by email or by displaying notices
or links to notices on www.open.collab.net or any successor site.
-
diff --git a/PKGBUILD b/PKGBUILD
index d256f5226a2d..9a37d4e9eb68 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer : Sebastian Lau <lauseb644@gmail.com>
+# Maintainer : Sebastian Lau <lauseb644 _at_ gmail .dot. com>
# Contributor: Martin Wimpress <code@flexion.org>
# Contributor: Liganic <liganic-aur@gmx.org>
# Contributor: Bernd Amend <berndamend@web.de>
# Contributor: Holodoc <archlinux@bananapro.de>
pkgname=giteye
-pkgver=1.11.0
+pkgver=1.12.0
pkgrel=1
pkgdesc="A desktop for Git. It works with TeamForge, CloudForge, GitHub and other Git services."
arch=('i686' 'x86_64')
@@ -16,16 +16,16 @@ makedepends=('unzip')
options=('!strip')
source=("LICENSE"
"${pkgname}.desktop")
-md5sums=('4df23a2c4f45c567feae7665694cd11a'
+md5sums=('29a5e78a36cabce86274d07ea11dd502'
'3144b18d4ddf6ac166afe374872ce4b4')
-md5sums_x86_64=('a6c3e91d9dee12877a27aafabc77f38e')
-md5sums_x86=('2ab57f083344ead599d0f64b811adc36')
+md5sums_i686=('02909e014f13dd29127887b02dbad1eb')
+md5sums_x86_64=('ecff81dcaee493852ea66a105948af13')
-_subfolder="61/11867"
+_subfolder="61/12536"
_antver="1.9.4.v201504302020"
source_x86_64=("https://downloads-guests.open.collab.net/files/documents/${_subfolder}/GitEye-${pkgver}-linux.x86_64.zip")
-source_x86=("https://downloads-guests.open.collab.net/files/documents/${_subfolder}/GitEye-${pkgver}-linux.x86.zip")
+source_i686=("https://downloads-guests.open.collab.net/files/documents/${_subfolder}/GitEye-${pkgver}-linux.x86.zip")
noextract=(*.zip) # extract nothing
@@ -35,14 +35,19 @@ package() {
msg2 "Extracting GitEye from archive..."
install -Ddm755 "${pkgdir}/opt/${pkgname}/"
install -Ddm755 "${pkgdir}/usr/bin/"
- unzip -q ${noextract} -d "${pkgdir}/opt/${pkgname}/"
+
+ if [[ "$CARCH" = "i686" ]]; then
+ unzip -q "GitEye-${pkgver}-linux.x86.zip" -d "${pkgdir}/opt/${pkgname}/"
+ else
+ unzip -q "GitEye-${pkgver}-linux.x86_64.zip" -d "${pkgdir}/opt/${pkgname}/"
+ fi
msg2 "Linking executable..."
ln -s "/opt/${pkgname}/GitEye" "${pkgdir}/usr/bin/"
msg2 "Installing LICENSE..."
- if [[ "$CARCH" = "x_86_64" ]]; then
- sed -i 's/32-bit/64-bit/' LICENSE
+ if [[ "$CARCH" = "i686" ]]; then
+ sed -i 's/64-bit/32-bit/' LICENSE
fi
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"