summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rwxr-xr-x.gitignore2
-rw-r--r--PKGBUILD43
3 files changed, 29 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09ce83033107..908f786bf2a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = gitgudcli-git
- pkgdesc = Brings pokemon to the terminal using the power of cowsay.
- pkgver = 1.0.2
+ pkgdesc = An easy to use CLI for the GitGud modular Git model.
+ pkgver = 2.2.2.r0.ge041976
pkgrel = 1
- url = https://github.com/HRKings/GitGudCLI.git
+ url = https://github.com/HRKings/gitgud-cli.git
arch = any
license = unknown
makedepends = git
- makedepends = dotnet-sdk
+ makedepends = go
provides = gitgudcli
- options = !strip
- source = git+https://github.com/HRKings/GitGudCLI.git
+ source = git+https://github.com/HRKings/gitgud-cli.git#branch=stable
md5sums = SKIP
pkgname = gitgudcli-git
diff --git a/.gitignore b/.gitignore
index 0271c7a238ea..36e7fff77797 100755
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-GitGudCLI/
+gitgud-cli/
*.pkg.tar.*
src/
srcdir/
diff --git a/PKGBUILD b/PKGBUILD
index ac923ef53ec5..3a71178ee551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
# Maintainer: HRKings <hrkings@***.com>
pkgname=gitgudcli-git
-_pkgname=GitGudCLI
-pkgver=1.0.2
+_pkgname=gitgud-cli
+pkgver=2.2.2.r0.ge041976
pkgrel=1
-pkgdesc="Brings pokemon to the terminal using the power of cowsay."
+pkgdesc="An easy to use CLI for the GitGud modular Git model."
arch=(any)
-url="https://github.com/HRKings/GitGudCLI.git"
+url="https://github.com/HRKings/gitgud-cli.git"
license=('unknown')
-makedepends=('git' 'dotnet-sdk')
+makedepends=('git' 'go')
provides=(gitgudcli)
-source=("git+${url}")
+source=("git+${url}#branch=stable")
md5sums=('SKIP')
-options=(!strip)
-package() {
- cd ${_pkgname}
-
- # Move to the stable branch
- git checkout stable
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
- # Install the README
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+build() {
+ cd "${_pkgname}"
- # Cd into project
- cd ${_pkgname}
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o ${_pkgname} -ldflags "-extldflags ${LDFLAGS} -s -w -X main.version=${pkgver}" main.go
+}
- # Compile with all the flags
- dotnet publish -c Release -r linux-x64 --self-contained true -p:PublishSingleFile=true -p:PublishReadyToRun=true -o ./compiled
+package() {
+ # Install the README
+ install -Dm644 ${_pkgname}/README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
# Install the CLI
- install -Dm755 ./compiled/GitGudCLI "${pkgdir}"/usr/bin/gitgud
-} \ No newline at end of file
+ install -Dm755 ${_pkgname}/gitgud-cli "${pkgdir}"/usr/bin/gitgud
+}