summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02aa16cc0c44..78956381dd77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitlab-glab-git
pkgdesc = An open source GitLab CLI tool written in Go
- pkgver = v1.10.0.r20.ge626fce
- pkgrel = 1
+ pkgver = 1.15.0.r30.g9371da9
+ pkgrel = 2
url = https://github.com/profclems/glab
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 9fe458b7c201..fe2f4defd25e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=gitlab-glab-git
_reponame=glab
-pkgver=1.10.0.r20.ge626fce
-pkgrel=1
+pkgver=1.15.0.r30.g9371da9
+pkgrel=2
epoch=
pkgdesc="An open source GitLab CLI tool written in Go"
arch=(x86_64)
@@ -52,4 +52,9 @@ package() {
cd "${_reponame}"
install -Dm755 build/main "$pkgdir"/usr/bin/glab
install -Dm644 $srcdir/${_reponame}/LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Shell completions
+ build/main completion -s bash | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/glab"
+ build/main completion -s zsh | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_glab"
+ build/main completion -s fish | install -Dm644 /dev/stdin "${pkgdir}/usr/share/fish/vendor_completions.d/glab.fish"
}