summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--config.cfg113
3 files changed, 10 insertions, 121 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf1676b346d4..669e786ffba7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = gitlab-pages
pkgdesc = GitLab Pages daemon used to serve static websites for GitLab users
pkgver = 1.38.0
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/gitlab-org/gitlab-pages
arch = x86_64
arch = i686
license = MIT
makedepends = go
backup = etc/gitlab-pages/config.cfg
+ backup = etc/gitlab-pages/service.env
source = https://gitlab.com/gitlab-org/gitlab-pages/-/archive/v1.38.0/gitlab-pages-v1.38.0.tar.bz2
- source = config.cfg
source = gitlab-pages.service
source = service.env
sha256sums = 02b6d5329d62282e5caa31751c855af54456f363284dd467550a31ee864dd7bf
- sha256sums = 5e2135793d43ec2f3343b49cf45b00f44ef74e813c7d152d2e0ed46af5c25122
sha256sums = ae62235f0fd66eaed7ad74048daf21b92058aba90e40fc2d3e7a684e9883c32e
sha256sums = fd8f9b60e2247077ad00765904237b6b1c36b11a952cd3b1ad88e74417b82a96
diff --git a/PKGBUILD b/PKGBUILD
index b274abad763d..d17896f33025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,18 @@
pkgname=gitlab-pages
pkgver=1.38.0
-pkgrel=2
+pkgrel=3
pkgdesc='GitLab Pages daemon used to serve static websites for GitLab users'
url="https://gitlab.com/gitlab-org/$pkgname"
license=('MIT')
arch=('x86_64' 'i686')
makedepends=('go')
source=("$url/-/archive/v$pkgver/$pkgname-v$pkgver.tar.bz2"
- 'config.cfg'
"$pkgname.service"
'service.env')
-backup=("etc/$pkgname/config.cfg")
+backup=("etc/$pkgname/config.cfg"
+ "etc/$pkgname/service.env")
sha256sums=('02b6d5329d62282e5caa31751c855af54456f363284dd467550a31ee864dd7bf'
- '5e2135793d43ec2f3343b49cf45b00f44ef74e813c7d152d2e0ed46af5c25122'
'ae62235f0fd66eaed7ad74048daf21b92058aba90e40fc2d3e7a684e9883c32e'
'fd8f9b60e2247077ad00765904237b6b1c36b11a952cd3b1ad88e74417b82a96')
@@ -30,11 +29,15 @@ build() {
-modcacherw \
-ldflags "-extldflags \"$LDFLAGS\" -X main.VERSION=$pkgver" \
.
+ ./$pkgname -help 2>&1 |
+ sed -ne '/=/{s/^ -//;s/\([^:]*\): \(.*\)/# \2\n#\1\n/;p}' |
+ sed -e '/daemon-.id=/{s/^#//;s/=0/=105/}' \
+ > config.cfg
}
package() {
cd "$pkgname-v$pkgver"
install -Dm755 -t "$pkgdir/usr/bin/" "$pkgname"
- install -Dm644 -t "$pkgdir/etc/$pkgname/" "$srcdir/"{config.cfg,service.env}
+ install -Dm644 -t "$pkgdir/etc/$pkgname/" config.cfg "$srcdir/service.env"
install -Dm644 -t "$pkgdir/usr/lib/systemd/system/" "$srcdir/$pkgname.service"
}
diff --git a/config.cfg b/config.cfg
deleted file mode 100644
index 190100357d41..000000000000
--- a/config.cfg
+++ /dev/null
@@ -1,113 +0,0 @@
-# The path to the certificate file for the admin API (optional)
-#admin-https-cert=string
-
-# The path to the key file for the admin API (optional)
-#admin-https-key=string
-
-# The listen address for the admin API HTTPS listener (optional)
-#admin-https-listener=string
-
-# Path to the file containing the admin secret token
-#admin-secret-path=string
-
-# The path for the admin API unix socket listener (optional)
-#admin-unix-listener=string
-
-# API URL to proxy artifact requests to, e.g.: 'https://gitlab.com/api/v4'
-#artifacts-server=string
-
-# Timeout (in seconds) for a proxied request to the artifacts server (default 10)
-#artifacts-server-timeout=int
-
-# GitLab application Client ID
-#auth-client-id=string
-
-# GitLab application Client Secret
-#auth-client-secret=string
-
-# GitLab application redirect URI
-#auth-redirect-uri=string
-
-# Cookie store hash key, should be at least 32 bytes long.
-#auth-secret=string
-
-# DEPRECATED, use gitlab-server instead. GitLab server, for example https://www.gitlab.com
-#auth-server=string
-
-# Drop privileges to this group
-# Arch: chroot to GitLab group by default
-daemon-gid=105
-
-# Fall back to a non-bind-mount chroot of -pages-root when daemonizing
-#daemon-inplace-chroot
-
-# Drop privileges to this user
-# Arch: chroot to GitLab user by default
-daemon-uid=105
-
-# Disable cross-origin requests
-#disable-cross-origin-requests
-
-# GitLab server, for example https://www.gitlab.com
-#gitlab-server=string
-
-# Use default list of cipher suites, may contain insecure ones like 3DES and RC4
-#insecure-ciphers
-
-# The address(es) to listen on for HTTP requests
-#listen-http=value
-
-# The address(es) to listen on for HTTPS requests
-#listen-https=value
-
-# The address(es) to listen on for proxy requests
-#listen-proxy=value
-
-# The log output format: 'text' or 'json' (default "text")
-#log-format=string
-
-# Verbose logging
-#log-verbose
-
-# Limit on the number of concurrent connections to the HTTP, HTTPS or proxy listeners (default 5000)
-#max-conns=uint
-
-# The address to listen on for metrics requests
-#metrics-address=string
-
-# The domain to serve static pages (default "gitlab-example.com")
-#pages-domain=string
-
-# The directory where pages are stored (default "shared/pages")
-# Arch: chroot to default pages dir
-pages-root=/var/lib/gitlab/shared/pages
-
-# The url path for a status page, e.g., /@status
-#pages-status=string
-
-# Redirect pages from HTTP to HTTPS
-#redirect-http
-
-# The default path to file certificate to serve static pages
-#root-cert=string
-
-# The default path to file certificate to serve static pages
-#root-key=string
-
-# The address for sending sentry crash reporting to
-#sentry-dsn=string
-
-# The environment for sentry crash reporting
-#sentry-environment=string
-
-# Specifies the maximum SSL/TLS version, supported values are "ssl3", "tls1.0", "tls1.1", "tls1.2", "tls1.3"
-#tls-max-version=string
-
-# Specifies the minimum SSL/TLS version, supported values are "ssl3", "tls1.0", "tls1.1", "tls1.2", "tls1.3" (default "tls1.2")
-#tls-min-version=string
-
-# Enable HTTP2 support (default true)
-#use-http2
-
-# Show version
-#version