summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b268e1f52c8..83bd810fa623 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gitleaks
pkgdesc = Audit Git repos for secrets and keys
- pkgver = 7.5.0
+ pkgver = 7.6.0
pkgrel = 1
url = https://github.com/zricethezav/gitleaks
arch = x86_64
@@ -8,8 +8,7 @@ pkgbase = gitleaks
license = MIT
makedepends = go
depends = glibc
- source = https://github.com/zricethezav/gitleaks/archive/v7.5.0/gitleaks-v7.5.0.tar.gz
- sha256sums = 9b06dbec9d1bc220630bb85298158d8a54d4be6f068472a0b3a0cc7a89cdfec7
+ source = https://github.com/zricethezav/gitleaks/archive/v7.6.0/gitleaks-v7.6.0.tar.gz
+ sha256sums = 922af2a6f3945954aacdf61919508d360685ee6fa165eab5070009ca9dcd523f
pkgname = gitleaks
-
diff --git a/PKGBUILD b/PKGBUILD
index da95295cc230..058c560fa0c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Daniel M. Capella <polycitizen@gmail.com>
pkgname=gitleaks
-pkgver=7.5.0
+pkgver=7.6.0
pkgrel=1
pkgdesc='Audit Git repos for secrets and keys'
url=https://github.com/zricethezav/gitleaks
@@ -11,22 +11,23 @@ license=('MIT')
depends=('glibc')
makedepends=('go')
source=("$url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha256sums=('9b06dbec9d1bc220630bb85298158d8a54d4be6f068472a0b3a0cc7a89cdfec7')
+sha256sums=('922af2a6f3945954aacdf61919508d360685ee6fa165eab5070009ca9dcd523f')
build() {
cd "$pkgname-$pkgver"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build .
+ go build -ldflags "-X=github.com/zricethezav/gitleaks/v${pkgver%%.*}/version.Version=$pkgver -extldflags \"$LDFLAGS\"" .
}
package() {
cd "$pkgname-$pkgver"
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
- install -Dm755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/"$pkgname"/README.md
+ install -Dm644 examples/* -t"$pkgdir"/usr/share/doc/"$pkgname"/examples/
+ install -Dm755 "$pkgname" "$pkgdir"/usr/bin/"$pkgname"
}
# vim:set ts=2 sw=2 et: