summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b8db2a6e90b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Mar 14 04:40:27 UTC 2018
+pkgbase = gitleaks
+ pkgdesc = Audit Git repos for secrets and keys
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/zricethezav/gitleaks
+ arch = x86_64
+ license = GPL3
+ makedepends = go-pie
+ depends = glibc
+ source = gitleaks-0.4.0.tar.gz::https://github.com/zricethezav/gitleaks/archive/v0.4.0.tar.gz
+ sha512sums = 82855edb5d25373c76bc0fdfa5eb186f9cfbc2d60e6073980917d5adb57068fa4a3751c42ac4846b439492f5e377d4f2ef8b6567e12e6477c70c22c0118ab7b4
+
+pkgname = gitleaks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e196574f741
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Daniel M. Capella <polycitizen@gmail.com>
+
+pkgname=gitleaks
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Audit Git repos for secrets and keys'
+url=https://github.com/zricethezav/gitleaks
+arch=('x86_64')
+license=('GPL3')
+depends=('glibc')
+makedepends=('go-pie')
+source=("gitleaks-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('82855edb5d25373c76bc0fdfa5eb186f9cfbc2d60e6073980917d5adb57068fa4a3751c42ac4846b439492f5e377d4f2ef8b6567e12e6477c70c22c0118ab7b4')
+
+prepare() {
+ mkdir -p src/github.com/zricethezav
+ ln -rsnf gitleaks-$pkgver src/${url#*//}
+}
+
+build() {
+ cd src/${url#*//}
+ export GOPATH="$srcdir"
+ go build -v
+}
+
+package() {
+ cd gitleaks-$pkgver
+ install -Dm755 gitleaks "$pkgdir"/usr/bin/gitleaks
+}
+
+# vim:set ts=2 sw=2 et: