summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
-rw-r--r--requirements.txt.patch16
-rw-r--r--setup.py.patch23
4 files changed, 63 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8298a8c4dc05..7561a5c56988 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,25 @@
# Generated by mksrcinfo v8
-# Sat Jun 18 18:04:51 UTC 2016
+# Sat Dec 31 16:54:24 UTC 2016
pkgbase = gitlint
pkgdesc = Git commit message linter
- pkgver = 0.7.1
+ pkgver = 0.8.0
pkgrel = 1
url = https://jorisroovers.github.io/gitlint/
arch = any
license = MIT
makedepends = python-setuptools
depends = python
+ depends = python-arrow
depends = python-click
depends = python-ordereddict
depends = python-sh
options = !emptydirs
- source = gitlint-0.7.1.tar.gz::https://codeload.github.com/jorisroovers/gitlint/tar.gz/v0.7.1
- sha256sums = 0c4fccf19586e56168e936abca23aa60b6ac62db226737c733a48b3521d1ecd1
+ source = gitlint-0.8.0.tar.gz::https://codeload.github.com/jorisroovers/gitlint/tar.gz/v0.8.0
+ source = requirements.txt.patch
+ source = setup.py.patch
+ sha256sums = dbbbc8741fc4f9ede748fdeb8136bdaffe9b2a0bf66e16baf87ebf539c814d98
+ sha256sums = e3bb9e56ee1d971f828d5cf3cff1b6293fc5860460670fd5114c6546f74339e4
+ sha256sums = 0bff8c9f7849cc16fcc3b124ccdb2fd7af25834372eedd82b381016524b5b368
pkgname = gitlint
diff --git a/PKGBUILD b/PKGBUILD
index efd91834befb..970705b60c5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=gitlint
-pkgver=0.7.1
+pkgver=0.8.0
pkgrel=1
pkgdesc="Git commit message linter"
arch=('any')
-depends=('python' 'python-click' 'python-ordereddict' 'python-sh')
+depends=('python'
+ 'python-arrow'
+ 'python-click'
+ 'python-ordereddict'
+ 'python-sh')
makedepends=('python-setuptools')
url="https://jorisroovers.github.io/gitlint/"
license=('MIT')
options=(!emptydirs)
-source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/jorisroovers/$pkgname/tar.gz/v$pkgver)
-sha256sums=('0c4fccf19586e56168e936abca23aa60b6ac62db226737c733a48b3521d1ecd1')
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/jorisroovers/$pkgname/tar.gz/v$pkgver
+ requirements.txt.patch
+ setup.py.patch)
+sha256sums=('dbbbc8741fc4f9ede748fdeb8136bdaffe9b2a0bf66e16baf87ebf539c814d98'
+ 'e3bb9e56ee1d971f828d5cf3cff1b6293fc5860460670fd5114c6546f74339e4'
+ '0bff8c9f7849cc16fcc3b124ccdb2fd7af25834372eedd82b381016524b5b368')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- msg2 'Fixing setup.py...'
- sed -i 's/Click==5.1/Click/' setup.py
+ msg2 'Loosening PyPi dependency restrictions...'
+ patch -p1 < "$srcdir/requirements.txt.patch"
+ patch -p1 < "$srcdir/setup.py.patch"
}
build() {
diff --git a/requirements.txt.patch b/requirements.txt.patch
new file mode 100644
index 000000000000..6539c3739f2d
--- /dev/null
+++ b/requirements.txt.patch
@@ -0,0 +1,16 @@
+--- ./requirements.txt 2016-12-31 08:51:58.490847575 -0800
++++ ./requirements.txt 2016-12-31 08:52:10.431399210 -0800
+@@ -1,7 +1,6 @@
+ setuptools
+-wheel==0.24.0
+-Click==6.6
+-sh==1.11
+-arrow==0.10.0
+-ordereddict==1.1
+-importlib==1.0.3; python_version < '2.7'
+\ No newline at end of file
++wheel
++Click
++sh
++arrow
++ordereddict
diff --git a/setup.py.patch b/setup.py.patch
new file mode 100644
index 000000000000..834fc4b62605
--- /dev/null
+++ b/setup.py.patch
@@ -0,0 +1,23 @@
+--- ./setup.py 2016-12-31 08:50:31.153301858 -0800
++++ ./setup.py 2016-12-31 08:50:43.154796909 -0800
+@@ -57,16 +57,11 @@
+ "License :: OSI Approved :: MIT License"
+ ],
+ install_requires=[
+- 'Click==6.6',
+- 'sh==1.11',
+- 'arrow==0.10.0',
+- 'ordereddict==1.1',
++ 'Click',
++ 'sh',
++ 'arrow',
++ 'ordereddict',
+ ],
+- extras_require={
+- ':python_version == "2.6"': [
+- 'importlib==1.0.3',
+- ],
+- },
+ keywords='gitlint git lint',
+ author='Joris Roovers',
+ url='https://github.com/jorisroovers/gitlint',