summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b921b07bf5de..d3af8c6e2f47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = gjdoc
pkgdesc = GNU Classpath JavaDoc implementation
pkgver = 0.7.9
- pkgrel = 2
+ pkgrel = 3
url = http://savannah.gnu.org/projects/classpath/
arch = i686
arch = x86_64
license = GPL
- depends = gcc-gcj>=4.3.1
- noextract = antlr-2.7.5.jar
+ depends = gcc-gcj>=4.9.2
+ noextract = antlr-2.7.7.jar
options = !libtool
+ options = !buildflags
source = http://ftp.gnu.org/gnu/classpath/gjdoc-0.7.9.tar.gz
- source = http://www.antlr2.org/download/antlr-2.7.5.jar
+ source = http://www.antlr2.org/download/antlr-2.7.7.jar
md5sums = 24cade2efe22d5adefcbabb21f094803
- md5sums = 6d57df718efd2a03981c309ce3330a1f
+ md5sums = f8f1352c52a4c6a500b597596501fc64
pkgname = gjdoc
diff --git a/PKGBUILD b/PKGBUILD
index 932cfd52d31a..ada1521d64a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,29 @@
pkgname=gjdoc
pkgver=0.7.9
-pkgrel=2
+pkgrel=3
pkgdesc="GNU Classpath JavaDoc implementation"
arch=(i686 x86_64)
license=('GPL')
url="http://savannah.gnu.org/projects/classpath/"
-depends=('gcc-gcj>=4.3.1')
-options=('!libtool')
-noextract=('antlr-2.7.5.jar')
+depends=('gcc-gcj>=4.9.2')
+options=('!libtool' '!buildflags')
+noextract=('antlr-2.7.7.jar')
source=(http://ftp.gnu.org/gnu/classpath/${pkgname}-${pkgver}.tar.gz
- http://www.antlr2.org/download/antlr-2.7.5.jar)
+ http://www.antlr2.org/download/antlr-2.7.7.jar)
md5sums=('24cade2efe22d5adefcbabb21f094803'
- '6d57df718efd2a03981c309ce3330a1f')
+ 'f8f1352c52a4c6a500b597596501fc64')
build() {
- export -n CFLAGS
- export -n CXXFLAGS
- export -n LDFLAGS
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --with-antlr-jar=${srcdir}/antlr-2.7.5.jar || return 1
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --with-antlr-jar=${srcdir}/antlr-2.7.7.jar
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
make || find . -type f -name '*.o' | while read f; do objcopy -L '_ZGr8_$_dummy' $f; done
- make || return 1
+ make GCJFLAGS='-g -O2 -fsource=1.3'
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ cd $pkgname-$pkgver
+ make DESTDIR=${pkgdir} install
}